Intel Edison not finding Nya Wi-Fi connections

When I plug in the Intel Edison and power on the RoboCore, The right hand Power lED turns Red and the Left is an off green.
I’m connecting the USB cable to UE as directed.
And plunging in to my Android Samsung Note II phone.
I have installed the RoboCore application and it finds the Intel Edison and has the entry for finding Wi-FI and nothing is discovered.
When I disconnect the Intel Edison from the RoboCore and plug my Note phone in to the UC connection it connects to my registered connection on and shows:
Platform status: Connected
Device mode: Accessory Device, Bootloader
Local Serial: No Device
It is getting an IP and using port 6800
When there is no Intel Edison installed the
power light is solid green
L1 Blinking Geen
L2 Solid Red
L3 Yellow
My questions are:

  1. Am I doing something wrong
  2. Is there an issue with the Intel Edison Hardware
  3. Is there an issue with the RoboCore hardware.

Hi Bill, I suggest to experiment at first with configuration: RoboCORE + Android smartphone (connected to UC). Try programming through WebIDE, remote control, robot’s user interface, telepresence features - simply build your Ralph with Android device at first to get familiar with RoboCORE behaviour, etc.

If all is working, now it’s time to test configuration with Intel Edison. If there will be any problem, we will know where to find solution.

I’ve connected and the when I installed the latest Firmware V3 release it stopped connecting.
What do I do now?

Hello Bill, since yesterday new version of Android app is available on Google Play (v 1.2.6 - ). We suggest to update your Android app and try again (but with Intel Edison unplugged).

Moreover make sure that in settings.h file there is:
#define PLATFORM_DEVICE Usb” line (if you use Android smartphone).
In case of using RoboCORE with Edison inside RoboCORE this line should be like this: “#define PLATFORM_DEVICE Edison”.


I had installed the latest RoboCORE app before I had updated the firmware to V3.
I validated it and it is version: 1.26.6 Revision: 0295033
I was getting:
Platform Staus: Not connected
Device mode: Accessory device
Local serial: 1 92,168,1,33:6800
L1: off
L2: off
L3: off
PWR: on
Android running on a Samsung Note II

Now I’m getting:

Platform Staus: Not connected
Device mode: No device
Local serial: No Device
L1: off
L2: off
L3: off
PWR: on
Android running on a Samsung Galaxy Note II

It’s now started to bounce between (see following)

Platform Staus: Not connected. And Connected and the Not Connected.

Device mode: Accessory device and No Device
Local serial: 1 92,168,1,33:6800 and No Device
L1: off and Blinking
L2: off
L3: off
PWR: on
Android running on a Samsung Note II

Interesting, if the unit when first turned on and the Android phone is just powered on.
The unit connects and I can see it is connected in the RoboCORE connection and the unit including the video cam in the bottom right of the unit, then it bounces on-line and off, then off

Hi Bill, maybe this will help:
a) There was a bug in version 1.2.6 (of Android app), but 1.2.8 is now available. Please update your app and try again. If it doesn’t help, try with points “b”, “c” and “d”.
b) Check whether your Android device is connected to the good USB-A port (this should be the bottom one).
c) Unplug USB cable and plug this again.
d) Kill RoboCORE Android app on your device - (RoboCORE must be unplugged during killing application)

Thank you for detailed information about your problems!

Have installed requested version and have the same problem.
No even connecting now.

Hi Bill,

On one smartphone we’ve noticed that usb connection works better if USB Debugging option is checked, could you please try to do it?

Useful link: How to Enable USB Debugging Mode on Android | Kingo Android Root

No change.
The unit doesn’t try to lock the kickstand or move the wheels or try to stay standing up.
I think I got a bad egg:(

I think I need a RoboCORE replacement.

Hi Bill, of course if your RoboCORE is broken, we will send you a replacement, but need to have a 100% sure where is the problem. Probably there is a strange problem with your Android device, so let’s try only RoboCORE hardware right now:

a) Update the RoboCORE bootloader: .
b) Try to program your RoboCORE with offline tools: . If you have Windows, we recommend this: .

It would be good idea to test RoboCORE with another Android devices if you have access to them.

I finely got connected.
I had to connect to a 9 volt AC power pack.
Then everything started running.
Now I have to calibrate as it keeps running the wheels except at a certain angle.
I can see via the URL connection page I’ve setup on your site.
Not sure why 6 AA batteries can’t give it enough power to operate.

1 Like

Maybe your batteries were not fully charged? Information about power supply can be found here: . If you use AA batteries, alkaine are better than zinc–carbon because of higher possible output current. When we powered Ralph using zinc-carbon batteries (are cheaper than alkaine), RoboCORE was reset due to lack of power.

RoboCORE isn’t designed for AC current, but 6 - 16 volt DC power pack would be fine, for example like this: .

I use AA batteries, after replacing new batteries, it got the platform connected. Thanks. a lot.

1 Like

Maybe it’s a hardware problem, You better ask a technician near from you to diagnose what happen on that.

My Ralph used to connect, but it no longer. Now it says “authorized but not connected”. I assume I need to perform some sort of firmware update and found some updates in the download section but there is no readme to walk me through how to perform the update. I have three robocore’s and all three are registered, but none of them will connect. Currently, I am attempting to connect via android and Intel Edison. Please assist.

We are aware of this problem and we are working on it.

Hi Anthony, thank you for your feedback! Now everything works fine. Please remove RoboCORE app, and install this one: . Unfortunately update of old RoboCORE app doesn’t work, and you should remove this and install the new one. Let me know whether everything works for you right now :slight_smile: