[ Solved] Rosbot 2R - gamepad tutorial

I am attempting to run the gamepad tutorial and immediately having problems again.

I cloned the tutorial from husarion/rosbot-gamepad.
Didn’t have a Logitech F710 gamepad controller but thought I might try to make it work with an inexpensive gamepad controller.
Only saw one instruction and that was to
docker compose up
I did that from the rosbot-gamepad directory and was greeted with

jcoco@ROScontrol:~/rosbot-gamepad$ docker compose up
invalid interpolation format for services.microros.devices.[].
You may need to escape any $ with another $.
required variable SERIAL_PORT is missing a value: err

Now I started guessing and looking at other compose files and tried

jcoco@ROScontrol:~/rosbot-gamepad$ docker compose up
[+] Running 3/3
⠿ Container rosbot-gamepad-rosbot-1 Running 0.0s
⠿ Container rosbot-gamepad-microros-1 Recrea… 1.5s
⠿ Container rosbot-gamepad-joy2twist-1 Runni… 0.0s
Attaching to rosbot-gamepad-joy2twist-1, rosbot-gamepad-microros-1, rosbot-gamepad-rosbot-1
Error response from daemon: error gathering device information while adding custom device “/dev/ttyAMA0”: no such file or directory

So not being able to find any additional clues or hints, I decided to ask for help from the community. I’m not sure what to set the environment variable value to. What port are we talking about? There is no serial connection…oh I’m so confused I don’t even know what to ask.

Sorry I neglected to copy the build file I am using.


image: husarion/joy2twist:humble-22-11-25
restart: unless-stopped
- /dev/input
- ./joy2twist.yaml:/joy2twist.yaml
command: >
ros2 launch joy2twist gamepad_controller.launch.py

image: husarion/rosbot:humble-22-11-25
restart: unless-stopped
command: ros2 launch rosbot_bringup rosbot_bringup.launch.py

image: husarion/micro-ros-agent:humble-22-11-25
restart: unless-stopped
- ${SERIAL_PORT:?err}
command: ros2 run micro_ros_agent micro_ros_agent serial -D $SERIAL_PORT serial -b 576000 # -v6

I notice the reason for the error message. There is no microros service in other joy2twist examples and I was wondering why it is here and what SERIAL_PORT value I should use. The IP address of the ROSbot2R?


there is a typo in the README. Connect the gamepad to the ROSbot’s USB and then run this repository on ROSbot. There is no need to do anything in the PC’s terminal in this example.
Let me know if that worked.

Jan Brzyk