[Solved] ROSbot Pro + 20.04 + ROS Noetic, rosbot_ekf firmware errors


I have encountered similar problems to the the following posts:

That is, I have recently flashed a ROSbot Pro 2.0 with the Noetic + 20.04 Upboard image (as listed on the Download page here). However, when running the following roslaunch, it results in the same error as the first link - that is a checksum error on failing to request/publish topics.

roslaunch rosbot_ekf all.launch rosbot_pro:=true

The first post, does not contain a solution, and I have tried the various other suggestions, including reinstalling the image, and re-flashing the robot with the firmware multiple times (including through reboots), changing the baud rate, etc. to no avail. I have also completely pulled/updated the rosbot_ekf package from the Husarion GitHub, but the issue persists.

One post mentioned an “bad firmware”, but I’m unsure where to acquire the “correct” firmware.

Is there a solution to this, perhaps something simple I’ve overlooked?

Thank you.


In futre investigation, I found this other post ( Tutorial 6/7 issue? ) that suggested the use of firmware_diff_noetic.bin.

I also tried this, but I get a ros serial error, which appears very similar to if I use the ROSbot firmware instead of the specific Rosbot pro. If this is the issue, is there a pro build of the noetic firmware v15.0?

Thank you.


Sorry for late reply.
The issue was within the Upboard image and it is resolved now.

Please go to our Downloads page and install fresh system image.
Remember to run ./flash_firmware.sh script and the issue should be resolved

Please let me know if everthing is working correctly now.
Hope it helps.

Hi Nicolas

Thank you for the reply. I will try this out in a couple days when I’m next working on the robots, and let you know of the results.


1 Like

Hello Nicolas,

I have tested the 20.04 + ROS Noetic for the Upboard (RosBot Pro 2.0), and this no longer has any error and appears to transmit all of the topics and transforms correctly. Thank you for the new image!

If there are any further problems I will post back.

Thank you.