[Solved] Rosbotxl navigation problem

Hi @avillaj88,

I guess it’s caused by the network configuration defined in the net.env file, and the culprit is the ROS_DOMAIN_ID=123 line. If you change it to 0 and restart containers you should be able to see ROSbot topics from your computer (I change repo for default 0 value).
However, I don’t understand why RViz didn’t work, unless you didn’t run it via compose.pc.yaml but from a terminal.
Let me know if it solved the problem If not you can also try setting up RMW_IMPLEMENTATION the same on both device (try rmw_cyclonedds_cpp or rmw_fastrtps_cpp)

Regards and I wish you success,
Rafał Górecki