Battery and charger


Recently, I received the chargers from Husarian team. I am wondering, if you can help me how to use it. When I connected, the charger displayed “connection brake”.
In fact this charger has two more connection. please see the attachment,




is the old charger working now with the same set of the batteries?
Please also try to charge with new (Redox) charger, but without balancing connector plugged in. Disconnect the 4-pin, white connector and leave only 2-wire connection from the charger side. Use “LiPo FAST CHARGE” mode, with the current about 1.5…2.0A.
If you can, please also check the voltage on each cell with multimeter.


Not now,
I tried your solution. But still the charger display “Connection Brake”

Before I tried both connection and now I cant charge the battery any more. what do you think?

would you please answer me ASAP?

I have sent you a private message because probably your issue needs an individual service action.

When we find the final solution that can help other users in the future, we will post it here.