Can't add CORE2-ROS to cloud

Yesterday I was able to add a CORE2-ROS to the cloud, a while later the cloud said the device was offline. Since then I’ve tried to add the device to the cloud many times in multiple ways. I have even flashed a new image to it. But that doesn’t work.

What I’m doing:

  1. Boot up the CORE2-ROS
  2. Get the code from ‘add new’ from the cloud
  3. Hold the hCfg button for a couple of seconds
  4. Connect to the CORE2-ROS via
  5. Enter the Wi-Fi password
  6. Paste the code from the cloud
  7. Now it says to close the window so I do that, but the device won’t show up in the cloud even after restarting.

The status LEDS show:
L1: ON

None of the LEDS are blinking.

I’ve been trying to fix it (also looking through answers given in this community) and I think a big indicator that somethings wrong is that L1 is constantly burning. Also after many resets.

Hi M11,

I’ve check this using CORE2-ROS with RPi 3 B and everything work fine. Can you tell me what SBC do you use in your CORE2-ROS?

If you want to add device you have to chose option “Connect to account” it’s the last window.

Status of LEDs is fine. You can check meaning of it here.

I assure you that we will find out what the problem is.

Best regards,

Hey @Hubert_Zwiercan, thanks for replying.

So I’ve just flashed the CORE2 as well, the L1 LED does blink now.

I’ve redone the whole adding the device process to the cloud two times again, to no avail.

The model I’m using is the Raspberry Pi 3 Model B, the one you can order from your website. I’ve actually ordered two CORE2-ROS with the Raspberry, the other one is working but the other one has problems.

Hi M11,

Can you provide me output of this command sudo husarnet websetup from your CORE2-ROS (this one with configuration problem) in private message? I will log in if you have default login and password and will check what’s going on.

Best regards,

Check your inbox, I’ve sent you the link

Hi M11,

I’ve done some tests and I can’t connect this controller to Husarion Cloud neither.

We will send you replacement, but I want to be sure that the problem is with RPi or CORE2. Can you replace CORE2 from one of your CORE2-ROS and put it together with RPi from second set and Try to connect both of them to cloud one more time? After that we will be sure which device cause problem.

Please let me know the results.

Best regards,

Hey Hubert,

Okay, good to hear you will send a replacement. Thanks for your replies and help.

I will try to switch the CORE2 and RPi this afternoon or tomorrow and let you know what is the cause of the trouble.

Kind regards,



So I swapped the CORE2’s and the RPi’s and tried to configure them. Both devices could not be registered to the cloud anymore. So I don’t know what was broken.

Now I have swapped them back to the original setup, and both devices are now not able to be registered to the cloud…

Hi M11,

It’s very weird. Please turn on device which I used before. I will make few more tests.

Best regards,

I just turned the device on which was the first one to not work.

Hi M11,

I’ve done with this one. Can you send me a code for husarnet from second one and leave it turns on for a while?

Best regards,


I’ve got to go now, tomorrow we can try further I hope.

I couldn’t connect with the second CORE2-ROS anymore so I can’t provide you a link, the blue lights were also not flashing on that one now…


For anyone reading this in the future, in my case I needed a replacement for the CORE2-ROS. I’ve got to say that the customer service was excellent and helpful, really trying their best to fix the issue.

1 Like