[Closed] Autoware.Auto Demo

I’m now trying the Autoware demo with the SVL simulator and ran into a permission problem trying to start the ade.

cd autoware-playground/adehome/AutowareDemo/
sudo ade update-cli
(ADE cli is up-to-date.)

ade start --update --enter
(Got permission denied while trying to connect to the Diocker daemon socket at…
then it asked me for credentials. ??)

Tried to run as sudo and got couldn’t add root user because it already exists. In either case, I cannot start ade.

I can run the simulation environment and drive the car but I can’t run any of the simulations built into ade. Any suggestions?

Hi Joe,

May I ask you to share full error logs? It would be much easier to investigate that issue with these logs.

Best regards,

Here is what I have been able to accomplish successfully to date.

cd /usr/local/bin/
sudo wget https://gitlab.com/ApexAI/ade-cli/-/jobs/1341322851/artifacts/raw/dist/ade+x86_64
sudo mv ade+x86_64 ade
sudo chmod +x ade
sudo ./ade update-cli

sudo git clone https://github.com/husarion/autoware-playground.git

cd autoware-playground/adehome/AutowareDemo/
sudo ade update-cli

ade start --update --enter
cd AutowareDemo
vcs import < autoware.auto.foxy.repos

colcon build --symlink-install

stderr: rosapi
/home/jcoco/AutowareDemo/install/rosapi/lib/python3.8/site-packages/rosapi/params.py:123: SyntaxWarning: “is not” with a literal. Did you mean “!=”?
if default is not"":

echo ‘source /opt/AutowareAuto/setup.bash’ >> ~/.bashrc
echo ‘source ~/AutowareDemo/install/setup.bash’ >> ~/.bashrc


cd autoware-playground/Panther_simulator

Created a simulation in SVL and published it.


docker container kill $(docker ps -a -q --filter=“name=ade*”)
cd autoware-playground/adehome/AutowareDemo/
ade start

received a > prompt on the terminal

In another terminal window

Simulations → Run Simulation

I received no more displays and I’m not sure how to invoke rviz such as depicted in the demo. That is where I don’t know what to do next.
I tried using keyboard keys but the display doesn’t look the same as in the demo so I don’t think I’m driving. Interesting process to get to this point and I’m not sure how useful it would actually be for me since I can’t figger out how to use it…yet.

Hi Joe,

The day of release of this tutorial is 12th Feb 2022, Autowere get a lot of updates since this time. I’ve checked it, and it needs refreshing to work properly. We will do our best to make it work again soon.

Best regards,


Finally, we know more about the example of Autoware.Auto Simulation Demo. Unfortunately, at the moment, this demo may not work due to the simulator’s servers being down. This is an external problem. We are working on a new version of Autoware, but it is a separate topic, and it is not known when it will be released. Naturally, the relevant information was added at the beginning of the article.
Thanks for your patience @Joe_Worthit. This is closed.

Best regards
Jan Brzyk