[Closed] Left wheels will not spin


Last summer I received six rosbot 2Rs. The first robot I used originally worked. But now the left two wheels will not spin. There does not seem to be any physical damage to the unit as I have kept them in their storage case. I ran ros2 teleop_keyboard and the right two wheels functioned as expected.
The robot suffered no falling or high speed crash that should have broken anything.
I have the robot fully charged, again the right two wheels work fine.
(I did not update the wheels, they are the default ones that come with the Rosbot 2r)

Any help would be great.



This is most likely caused by one of the following possibilities.

  1. Motor cables have become disconnected (which may have been caused by tripping and driving on uneven surfaces).
  2. One of the two wheel controllers is damaged.

In order to find the cause, it will be helpful to check the correctness of the wheel readings from the encoder.

  1. Turn on the robot and connect to the robot.
  2. Start the nodes on the robot - command ~/ros_driver_start.sh.
  3. Analyze the topic _motors_response - the command ros2 topic echo /_motors_response and check whether the rotation of the wheels causes the appropriate change in the value.

Rafał Górecki

You can also try flash firmware.

  1. Turn on the robot and connect to the robot.
  2. Make sure no other Docker processes are running.
  • stop all containers: docker stop $(docker ps -a -q)
  • remove all containers: docker rm $(docker ps -a -q)
  1. Run the flashing script: ~/flash_firmware.sh
  2. Start the nodes on the robot - command ~/ros_driver_start.sh and make /cmd_vel tests.

Closing - over 2 weeks without a response.