[Closed] ROS #8 Tutorial - Map and robot not displaying correctly in Rviz

As the docker images don’t seem to be working correctly for me, I’ve been starting the robot using the following launch file:


`<param name="robot_description" command="$(find xacro)/xacro '$(find rosbot_description)/urdf/rosbot.xacro'"/>`

`<node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher"/>`

`<node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher"/>`

`<include file="$(find rosbot_ekf)launch/all.launch"/>`

`<node name="rplidarNode" pkg="rplidar_ros" type="rplidarNode">`
`<param name="serial_baudrate" type="int" value="256000"/>`

`<node pkg="tf" type="static_transform_publisher" name="static_transform_publisher_map_odom" args="0.5 0 0 0 0 0 map odom 100"/>`

`<node pkg="tf" type="static_transform_publisher" name="static_transform_publisher_baselink_laserframe" args="0 0 0 0 0 0 base_link laser_frame 100"/>`


I am currently having problems trying to implement the move_base.launch file from tutorial 8 path planning. When I run it it loads correctly at first but after a few seconds the robot model and laser_frame start going crazy and moving and glitching all over the screen. I have had a few similar problems with the slam.launch file in tutorial 7 as well but the glitching isn’t as bad and mostly stabilises after a few seconds.
I have tried using a broadcaster/listener instead of static transformations and had the same issues.

I am using a rosbot2 pro and are using the Noetic version 1.15.14, and all of the images are up to date.

Hi Daisy,
Please describe what is happening with docker that you think is not working.

Hi Rafal,

I made this post ROS #3 Tutorial - Rostopic echo /odom not working - #6 by daisy almost a month ago which was never responded to about my issue. But at this point I think I would rather not use the docker images as I have had many problems trying to use it and as I don’t completely know what they are doing (is there anywhere where I can see the code and commands that they do?) I prefer the level of control I have when using my own launch files.

Thanks Daisy

I’m sorry to hear that, but let’s start from the beginning because as I understand there can be 3 problems:

  1. Possible Docker problem.
  2. No odom.
  3. Move base problem.

I would like to solve these problems in that order. I understand that you may not like Docker due to data encapsulation, but thanks to this, our company is able to make sure that we both have identical software, thanks to which the number of variables affecting the robot’s behavior is smaller.
Once the bug is fixed, you will be able to create a launcher that will meet your requirements.

  1. Tell me if you accept this approach?
    2a. If so, tell me if:
    a) launching the microros and rosbot containers still prevents you from being able to control via the teleopt and topic odom is available and show logical and meaningful data.
    b) running astra, rplidar images you see appropriate topic.
    2b. If not, please use RViZ and check if topic odom, odom_filtered, tf look reasonable.

Best regards

This topic was automatically closed after 4 days. New replies are no longer allowed.