[Closed] ROSbot 2 PRO - RViz start problem

Hello Husarion,

This is Max. I just received the new Ros2Pro robot. Now I am trying to configure the robot following the quick start. I just want to confirm do I need to install the ROS Noetic. (When I Docker Compose Up, I can not get any information from the topic ‘rostopic echo /battery’ based on the current ROS Melodic.)

If we have to install the ROS Noetic, Why is the default configured OS Melodic rather than Noetic?


It seems that we can not use rviz as long as we ‘docker compose up -d ros-master rosbot’ even we have install the ROS Noetic. It will give us the info ‘could not contact ros master at [http://]’

Hello @Max97 and welcome to Husarion Community

It seems that the old system from ROS Melodic was actually installed in ROSbot incorrectly. We’re sorry for that.

Since you have reinstalled your system on ROS Noetic, you should have no problem installing the latest system image with ROS 2 Foxy on board, which we recommend due to the dynamic development of ROS 2 compared to ROS 1.

However, if you want to stay with ROS Noetic, I have to ask. The problem with connecting to the master occurs after entering the command docker compose... or after trying to start RViz? If the latter, how do you run RViz and on what device (robot or computer)?

Best regards
Jan Brzyk

Hello @JanBrzyk,

Thank you so much for your response.
The problem is: first, I enter the command ‘docker compose…’, then I start rviz. I run rviz on the robot and I tried two different commands ‘rviz’ and ‘rosrun rviz rviz’.


Hi @Max97!
Please send us the docker compose files and send the output when you try to open RViz.

Best regards,
Jakub Delicat

Thank you for your response! We have installed the foxy OS and it is working right now. By the way, given this case, could every project of the tutorial be implemented perfectly using ROS2? And should the side of PC be ROS1 or ROS2?


Hello @Max97

I’m not quite sure if I understand that question.

If you use Docker Containers on the PC the natively installed version of ROS doesn’t matter. For RViz, there are rviz and rviz2 packages.

Best regards
Jan Brzyk

Hi Max,

I had this issue as well. What I found was that it only worked by running roscore. However if you are already running ‘docker compose…’ then it will not let you run roscore, so you have to stop the docker from running (docker compose down), then start roscore first and then start the docker again. This then allowed me to start rviz as normal.

1 Like