[Closed] Unable to launch rosbot_ekf or update firmware | ROSbot


Since a few days ago, whenever I tried to launch rosbot_ekf using the Husarion Ubuntu 20.04 ROS noetic image, I got unable to sync with device, possible link problem or link software version mismatch such as hydro rosserial python with groovy Arduino.

Therefore, I tried to update the firmware of ROSbot. I followed the instruction here (CORE2 | Husarion and Firmware update fail - ROSBot2 Pro - #2 by Karol_Konkol) and ran ./flash_firmware.sh on tinkerboard. I got an error as shown below.


$ ./flash_firmware

I get:

Attempt 1 Can't init into bootloader: Can't read port or timeout

Attempt 2 Can't init into bootloader: Can't read port or timeout


I also tried to reinstall the system and run ./flash_firmware.sh to solve this problem. However, I still got the same error.

Now I have no idea how I can fix it. Everything worked fine before. Any guidance will be gratefully received. Thank you in advance.

Best Regards


There are leds on the rear panel of your robot. Do any of them light up orange when trying to flash firmware?

Can you tell me is it ROSbot pro or regular one and send me in private message serial numbers of your rosbot?

Best regards,

Hello Paweł,
Thanks for your reply. It is the regular ROSbot(the red one). And yes, whenever I run ./flash_firmware, the orange led will be kept turning on until 5 attempts finished. Additionally, I am also able to do the tutorial from CORE2 - quick start | Husarion.

And the serial number I will send you in private message.

Best regards


My initial guess is your GPIO or UART interface is broken. We will continue the details of the warranty and repair in a private chat.

Best regards,