CORE2+ROS does not find wireless

Hi. Desperately trying to get my new CORE2+ROS on line. hConfig connects to the system and when I run the “Wizard”, it says 'Select WiFi network for your CORE2…Scanning…

And just stays that way for 15 minutes+. There is an open WiFi available and visible on both the Android phone and my laptop, but nothing is ever offered to select in the hConfig app.

I should have mentioned, I have the version with the ASUS Tinker board.

Is there a way to bypass this? And other suggestions to get going?


To answer my own question, my Android phone is configured to use VPN. When the VPN was disabled, hConfig was able to see the available networks.

hConfig did not allow me to enter the password since the first character is lowercase. So for now, I had to use guest connection. I registered my device, but so far the cloud.husarions app is not able to connect to the device…

1 Like

Hi Terry, please try once more to enter the password for your Wi-Fi network. In the current version of hConfig app by default there is the uppercase, but you can change this, eg. in iPhone click this button:

You should be able to do this. I just checked once more, and on side and hConfig side everything works fine right now.

Please let me know about results

To add some somewhat relevant info:

I’ve also noticed some quirks regarding detecting WiFi networks when there is a colon in the SSID. Specifically, the hConfig stops reading/writing/displaying the SSID name when there is a colon in it. I ran into this the very first time I set my Core2 up, and it gave me an excuse to finally go in and change the SSID to something better (the colon was just a quick and dirty differentiation I used when setting up the WiFi).

So Name: subname is displayed as just Name by the app. Can be confusing for anyone who is running a dual-band network and has given their SSIDs a similar naming scheme. It also fails if the colon is at the start of the name. It doesn’t seem to detect/display the network at all. I haven’t played around to see if any other special characters cause exceptions when adding it to a network, but it might be worth considering if you run into a similar problem as @thealy, but are not using a VPN.

Thank you for the feedback Michael!

I haven’t seen SSID with characters like “:”, “,”, “.” etc. but because they are possible, we will update the string parser in hConfig app.

I got as far as trying to join the Wi-Fi on my iPhone, but I keep getting “password not accepted”. The app is telling me the pw is “husarion” – was that changed at some point? I have an old CORE2-ROS

it just connected. strange…

now the app is stuck in the setup wizard [step 1/3]

  1. select wifi network for your core2:


Stuck. iPhone settings show connected to Husarion Wi-Fi, but neither manual nor wizard work. Scanning QR code succeeds, but always a ‘failure to save to device’ error message; manual just hangs up with “scanning…” displayed forever*

*for relatively small values of forever

Hi Polycopter,

We’ll do our best to fix it for you asap.
Can you please tell us on which exact step the app is not letting you through?

Your issue might have been caused by a temporary issue. Are you still having problems with connecting the device?