Development on different network


At home this robot connects automatically to the cloud and together with my laptop I can develop and control it. My laptops display and keyboard become the command center to run my robot using the platform.ui functions.

Now and then I like this robot and my laptop to work/connect on a different network to show the cloud IDE.
The robot has been tailored to use my home-SSID and password, and at this moment I do not know how to make it otherwise…
At other location than home, doing the config-button and poweron sequence just restarts my current program and the leds indicate ‘not connected’.

What do I have to do to make a cloud connection for my robot in a new network?
(other than using another micro-SD)

Thanks and best regards,

Hi Fred,

right now the easiest way is to use hConfig app to connect your robot to different network. Use “manual config” button instead of “wizzard”. All you need to do is to change Wi-Fi network, so there is no need to click “add device” and scan QR code in

If you use CORE2-ROS you can log into it (using remote desktop, or through a monitor with HDMI port, mouse and keyboard connected directly to you CORE2-ROS), and from a Linux level add as many Wi-Fi network credentials as you want, to enable your device connect automatically if you change location.


Hi Dominik,
Thanks for your reply.
With my CORE2-ROS i am not able to use the hConfig app.
Power off, then press and hold config-button followed by power on, and holding the config-button for at least 15 seconds doesnot give the expected result, that LR1 and LR2 blinking alternately.
Instead the existing program gets working normally.
I do not know if this is a normal condition not being able to use the hConfig app anymore.

The other option is to change/add WIFI via ssh.
Knowing the WIFI info beforehand is not always the case.
So the change or addition of SSID+password has to be done on the site.
I like to have SSH headless-connection thrue bluetooth, can you help me on that?

Thanks and best,

Hi Fred,

it’s not a normal condition. You should be able to go through config process at any time.

The most probable reason why you’re not able to enter in the config mode is the hCFG button itself. Some of the boards that we’ve sent had a defective hCFG button, which initially worked during internal post-production tests (we test 100% of boards) but after some time they stop working properly.

The possible solutions:

  1. Make a short-circuits between hCFG testpoints that are located on opposite side to the button (on the bottom side of PCB). You need to keep the short circuit at least during first 5 seconds after powering on the CORE2.
  2. The better way is to solder the additional button using the wires - you will be sure that the electrical connection is reliable. Use the same testpoints that I mentioned above.
  3. The connection via SSH + Bluetooth or via Ethernet is also possible. This topic may help you:
    Ssh over bluetooth - Raspberry Pi Forums

Hi Radeknh,
Thanks for the 2 howto possibilties to enter in the terminal state.
Please can you tell in what file and directory where I can find my SSID and its password?

Changing the SSID of your CORE2ROS robot issue the following command
nmcli device wifi connect password