Error in terminal emulator

Hey there, can you tell me why do I get this error? i just entered this command and got that error :“roslaunch rosbot_webui demo_rosbot_pro.launch”.

Hello Newsight,

The errors are caused by problem with serial bridge communication.
This could happen, when CORE2 controller in ROSbot is flashed with wrong firmware.
Please make sure, that you CORE2 controller is flashed with ROSbot 2.0 PRO default firmware.


Thanks for letting me know what the cause of the error is.
can you instruct me how do I do that?

Hello Newsight,

Follow steps in ROSbot - quick start: Programming.
Just note that there is choice of default firmware for ROSbot 2.0 and ROSbot 2.0 PRO, choose the on appropriate for your device.


Hey, thank you again, it really worked but I have another question for you. when I keep with the instructions from ROSbot - quick start | Husarion, in the Usage section, the command worked but when I tried to type the robot IP on my phone browser(which was on the same network as the ROSbot 2.0 Pro) it didn’t show me anything. It should’ve shown me the interface.
Do you know what should I do?

Were you able to open the interface from different computer?
Were you able to open the interface locally on ROSbot by opening localhost on ROSbot browser?

you mean from the Husarion cloud? Unfortunately it does not show an interface neither in the cloud and from a different computer.

I meant typing ROSbot IP in web browser on different computer and typing localhost in web browser running on ROSbot.

I tried it right now. It says that the site can’t be reached on my ROSbot when typed localhost.

And also L1 is not blinking so it’s not the battery that causes the issue

It looks like the Nginx server is not configured on your ROSbot.

Check contents of /etc/nginx/sites-enabled/default file:

sudo nano /etc/nginx/sites-enabled/default

When following the tutorial, it should have had edited line:
root /var/www/html;
root /home/husarion/ros_workspace/src/rosbot_webui/edit;

If you have it already edited, there is nothing to change.
To exit text editor press: “Ctrl + x”, “y”, “Enter”

Restart Nginx server:

sudo systemctl restart nginx

If Nginx was not running, it will be started with this command.

Now you should be able to view the interface.


Job for nginx.service failed because the control process exited with error code. See “systemctl status nginx.service” and “journalctl -xe” for details.

Hello Newsight,

According to error shown, there is duplicated entry for default server.
Could you post here contents of your /etc/nginx/sites-enabled/default file?


It is working now, thanks. I probably edited the file wrong, so I downloaded a new one.
Just wondering, do you know why the camera looks a bit blurry/not shown on a full screen(black scars)? and when I try to move the ROSbot a bit, it shuts down(crashes).

Below camera view, there is a slider for depth clipping, you can use it to cut off elements which are further than selected distance. It can be switched to raw image from camera.

Regarding the ROSbot shutdowns, few things to check:

  1. Make sure batteries are fully charged.
  2. Make sure that ROSbot is within WiFi range all the time (try using ROSbot in different room or with another access point if possible)