Fisrt set up problem connecting

Sorry this is a real Nubee question… I have just got my Rosbot 2.0 Pro but am having trouble getting the Cloud to connect.

The system is connected to my home WiFi with a keyboard and mouse connected (I am writing this from the Rosbot) I have connected the device to my new cloud account (I believe - it is lited as Online in green.)

When I hit the device line I get the graphic in the middle with Loading … and the spinning circle, A green tick for connected to server, but a spinning wheel on connecting to device.

I have unlinked and tried again - but same result.

What have I missed here??


Hello Barry_Hendy

When you see status Online, then everything works as it should.
By clicking on device name, you try to open device control panel - this is not flashed by default, that is why you are getting stuck on Loading… status.
If you want to flash new software for ROSbot, then click Edit next to device name and choose IDE.
If you want to connect with ROSbot remote desktop for wireless control, it should be done with remote desktop client. You can find connecting details in Quick start manual.


Thanks Lukasz.

I have to say it is a bit annoying that a critical part of the process is listed as item 6 in the ‘how to start’ tutorial … and that key software cannot be pre-loaded or scripted. My ‘out of the box’ experience is not going very well …

I went through the quick start … I had a permissions error with the github steps so i had to sudo those steps. Is that normal or a problem? I am worried now all the steps there are set as SU only.

If i run the Load firmware project, I can then get past the connection - thanks. But I am now at a blank screen …

Does the load firmware process have to be run every time (annoying - can it be automated) or this this a one-time installation?

The UI Example in the IDE compiles with warnings - which a bit of a worry - but does appear to load - but when I connect I am only getting a blank screen. The same with the UI Example and FirstTry.

I can’t connect with a remote desktop. I can ping the vehicle (IP address) so I am confident it is there, but remote connection fails and a web browser gives a error 404.

if I connect with a screen and keyboard - and I run rosbot_webui demo_rosbot_pro I get:

husarion@husarion:~$ roslaunch rosbot_webui demo_rosbot_pro.launch
[demo_rosbot_pro.launch] is neither a launch file in package [rosbot_webui] nor is [rosbot_webui] a launch file name
The traceback for the exception was written to the log file

Sorry - lots of questions in here! I hope you can help!



perhaps I should add: i think the install has gone OK becuase the .launch file is there:

husarion@husarion:/home/rosbot_webui/launch$ ls
demo.launch demo_rosbot_pro.launch

or perhaps it is permissions:

husarion@husarion:/home/rosbot_webui/launch$ ls -l
total 8
-rw-r–r-- 1 root root 2467 May 18 09:35 demo.launch
-rw-r–r-- 1 root root 2470 May 18 09:35 demo_rosbot_pro.launch

Sorry … trying to get as much info as I can for you!

Thanks again.

Hi Lukasz,

I have sorted it out … I went back and re-ran all the instructions and now it is working. I must have missed something …

Sorry for the stream of questions …

However - the first-step instructions could be better presented to walk you through the process.

Thanks again …

Hello Barry,

I am glad to know that you solved your problem.

We are working on updated quick-start guide with more readable process.
Your input is valuable for us, thank you for posting it.