hConfig problems

Hello everyone,

I am unable to hConfig my ROSbot. When I press on hold the hCfg button the LR1 and LR2 LEDs are on but not blinking. The power LED is also on. Also, when I turn it on the L1 LED turns on and after a while it turns off while the LR1 and LR2 LEDs turn on. I have tried to reset the Core2 board by turning the board on while holding the reset button. I have also tried flashing the Core2 board with VS code, but I get ‘error1’ when configuring. It was working fine this past week until it suddenly stopped now. Thanks in advance!



Hello all,

Also flashing with the following step did not work.
Power down the boards.
Depress and HOLD the reset button on the Core2 board
Continue to hold and power up.
Hold - about 20-25 sec for me - until the LEDs blink on the Core2.
Release the reset

please give us the hint.

Hello Eric,

The LR1 and LR2 LEDs are controlled by TinkerBoard.
If you hold the hCfg button and turn on ROSbot, LEDs should be off for about 10 seconds, then on for 3 seconds. After this they should blink alternately.
Sometimes this process can take more time, especially when image was freshly written to SD card.

Did you do any changes on Linux image since the time it was working fine?
Is TinkerBoard booting properly, e.g. can you login to it through RDP or or by connecting with HDMI?


Hello Amin,

If LR1 and LR2 LEDs are blinking, then device is in configuration mode (connecting to cloud and WiFi) you should not flash new software to CORE2 board at that time.

When you are done with configuration, power off device and then power on without touching any buttons. Now you can flash CORE2 through cloud or USB.


I mean that I am unable to hConfig my ROSbot. I try to flash the core2 board and now still I am unable to hConfig.
We did not change Linux image since the time it was working fine.
How can I test that TinkerBoard booting properly?

The easiest way to test TinkerBoard is to plug monitor with HDMI cable, keyboard and mouse. All the plugs are on the rear panel of ROSbot.
If you see linux desktop on monitor and can login, then TinkerBoard is fine.


I tested the ROSbot and noting show up. How can I install a new OS on TinkerBoard?

Hi amin,

You have yo download the newest version of CORE2-ROS image from here, next use program to disk management and create only one partition on your SD card (you can use for example MiniTool Partition Wizard). The last step is flash a new image to the SD card (you can use Rufus or Etcher). In case of any problem with this few steps fell free to contact us.



I did the step but the problem does not solve. what should I do

would you please tell me what to do?

Hi amin,

I will ask you several questions that can help us to solve your problem.

  1. Are you able to enter the state where LR1, LR2 (blue and yellow) LEDs are blinking alternately?
  2. What about power supply, is the power LED (red) on? Are you able to measure the voltage on all 3 cells?
  3. Check if the antenna has a good connection.

It looks like Tinker Board is not working properly or the HDMI connection is not working. But the hConfig state is independent from ASUS Tinker Board SBC, so we can check if at least the CORE2 part is working fine.


Thank you for your answer.
1-Actually the LR1 and LR2 are not blinking and are constant (on without blinking).
2- Yes the red led is on. I will check the voltage and let you know.
3- How can I check that?

what should I do now?

would you please answer my question.


1 - This suggests a problem with SBC, but it can be software or hardware problem.
2 - Ok, if you are able to check the voltage, it would be great - many problems with all electronic devices are caused by power supply.
3 - I meant to check if it is properly tightened and not loose.

We are waiting for the results of the measurements and then we can decide if the service or replacement is needed.

I replaced the batteries and I have new battery now
but the problem still exist
what should I do?