Laser Readings

I am attempting to create a program to avoid obstacles. I first bring up the docker containers for the ROSbot2R from Husarion supplied containers as you can see in my terminal output.

Further planning wants me to take a look at the laser outputs to determine forward facing collision cone indexes. I am a little shocked and surprised at what my echo of the scan output shows. I’m an expert but I don’t believe I know how to interpret the readings. Shouldn’t they be continuous?

ON THE ROSBOT2R
[+] Running 3/3
⠿ Container rosbot-bringup-rplidar-1 Created 1.1s
⠿ Container rosbot-bringup-rosbot-1 Created 1.2s
⠿ Container rosbot-bringup-microros-1 Created 1.2s
Attaching to rosbot-bringup-microros-1, rosbot-bringup-rosbot-1, rosbot-bringup-rplidar-1
rosbot-bringup-microros-1 | [1674160895.635340] info | TermiosAgentLinux.cpp | init | running… | fd: 3
rosbot-bringup-microros-1 | [1674160895.637412] info | Root.cpp | set_verbose_level | logger setup | verbose_level: 4
rosbot-bringup-microros-1 | [1674160895.671182] info | Root.cpp | create_client | create | client_key: 0x4033E6BD, session_id: 0x81
rosbot-bringup-microros-1 | [1674160895.671402] info | SessionManager.hpp | establish_session | session established | client_key: 0x4033E6BD, address: 0
rosbot-bringup-microros-1 | [1674160895.723840] info | ProxyClient.cpp | create_participant | participant created | client_key: 0x4033E6BD, participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.727645] info | ProxyClient.cpp | create_topic | topic created | client_key: 0x4033E6BD, topic_id: 0x000(2), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.729876] info | ProxyClient.cpp | create_subscriber | subscriber created | client_key: 0x4033E6BD, subscriber_id: 0x000(4), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.740577] info | ProxyClient.cpp | create_datareader | datareader created | client_key: 0x4033E6BD, datareader_id: 0x000(6), subscriber_id: 0x000(4)
rosbot-bringup-microros-1 | [1674160895.745116] info | ProxyClient.cpp | create_topic | topic created | client_key: 0x4033E6BD, topic_id: 0x001(2), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.747023] info | ProxyClient.cpp | create_publisher | publisher created | client_key: 0x4033E6BD, publisher_id: 0x000(3), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.751844] info | ProxyClient.cpp | create_datawriter | datawriter created | client_key: 0x4033E6BD, datawriter_id: 0x000(5), publisher_id: 0x000(3)
rosbot-bringup-microros-1 | [1674160895.755112] info | ProxyClient.cpp | create_topic | topic created | client_key: 0x4033E6BD, topic_id: 0x002(2), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.757078] info | ProxyClient.cpp | create_publisher | publisher created | client_key: 0x4033E6BD, publisher_id: 0x001(3), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.760453] info | ProxyClient.cpp | create_datawriter | datawriter created | client_key: 0x4033E6BD, datawriter_id: 0x001(5), publisher_id: 0x001(3)
rosbot-bringup-microros-1 | [1674160895.764574] info | ProxyClient.cpp | create_topic | topic created | client_key: 0x4033E6BD, topic_id: 0x003(2), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.766901] info | ProxyClient.cpp | create_publisher | publisher created | client_key: 0x4033E6BD, publisher_id: 0x002(3), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.774600] info | ProxyClient.cpp | create_datawriter | datawriter created | client_key: 0x4033E6BD, datawriter_id: 0x002(5), publisher_id: 0x002(3)
rosbot-bringup-microros-1 | [1674160895.778643] info | ProxyClient.cpp | create_topic | topic created | client_key: 0x4033E6BD, topic_id: 0x004(2), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.780765] info | ProxyClient.cpp | create_publisher | publisher created | client_key: 0x4033E6BD, publisher_id: 0x003(3), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.793580] info | ProxyClient.cpp | create_datawriter | datawriter created | client_key: 0x4033E6BD, datawriter_id: 0x003(5), publisher_id: 0x003(3)
rosbot-bringup-microros-1 | [1674160895.797546] info | ProxyClient.cpp | create_topic | topic created | client_key: 0x4033E6BD, topic_id: 0x005(2), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.799459] info | ProxyClient.cpp | create_publisher | publisher created | client_key: 0x4033E6BD, publisher_id: 0x004(3), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.802569] info | ProxyClient.cpp | create_datawriter | datawriter created | client_key: 0x4033E6BD, datawriter_id: 0x004(5), publisher_id: 0x004(3)
rosbot-bringup-microros-1 | [1674160895.806922] info | ProxyClient.cpp | create_topic | topic created | client_key: 0x4033E6BD, topic_id: 0x006(2), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.808775] info | ProxyClient.cpp | create_publisher | publisher created | client_key: 0x4033E6BD, publisher_id: 0x005(3), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.811679] info | ProxyClient.cpp | create_datawriter | datawriter created | client_key: 0x4033E6BD, datawriter_id: 0x005(5), publisher_id: 0x005(3)
rosbot-bringup-microros-1 | [1674160895.815680] info | ProxyClient.cpp | create_topic | topic created | client_key: 0x4033E6BD, topic_id: 0x007(2), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.818231] info | ProxyClient.cpp | create_publisher | publisher created | client_key: 0x4033E6BD, publisher_id: 0x006(3), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.821760] info | ProxyClient.cpp | create_datawriter | datawriter created | client_key: 0x4033E6BD, datawriter_id: 0x006(5), publisher_id: 0x006(3)
rosbot-bringup-microros-1 | [1674160895.825990] info | ProxyClient.cpp | create_topic | topic created | client_key: 0x4033E6BD, topic_id: 0x008(2), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.828775] info | ProxyClient.cpp | create_publisher | publisher created | client_key: 0x4033E6BD, publisher_id: 0x007(3), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.842535] info | ProxyClient.cpp | create_datawriter | datawriter created | client_key: 0x4033E6BD, datawriter_id: 0x007(5), publisher_id: 0x007(3)
rosbot-bringup-microros-1 | [1674160895.845459] info | ProxyClient.cpp | create_topic | topic created | client_key: 0x4033E6BD, topic_id: 0x009(2), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.847355] info | ProxyClient.cpp | create_publisher | publisher created | client_key: 0x4033E6BD, publisher_id: 0x008(3), participant_id: 0x000(1)
rosbot-bringup-microros-1 | [1674160895.850314] info | ProxyClient.cpp | create_datawriter | datawriter created | client_key: 0x4033E6BD, datawriter_id: 0x008(5), publisher_id: 0x008(3)
rosbot-bringup-rplidar-1 | [INFO] [launch]: All log files can be found below /root/.ros/log/2023-01-19-20-41-36-147698-husarion-1
rosbot-bringup-rplidar-1 | [INFO] [launch]: Default logging verbosity is set to INFO
rosbot-bringup-rosbot-1 | [INFO] [launch]: All log files can be found below /root/.ros/log/2023-01-19-20-41-36-410367-husarion-1
rosbot-bringup-rosbot-1 | [INFO] [launch]: Default logging verbosity is set to INFO
rosbot-bringup-rplidar-1 | [INFO] [sllidar_node-1]: process started with pid [59]
rosbot-bringup-rplidar-1 | [sllidar_node-1] [INFO] [1674160896.755395772] [sllidar_node]: SLLidar running on ROS2 package SLLidar.ROS2 SDK Version:1.0.1, SLLIDAR SDK Version:2.0.0
rosbot-bringup-rplidar-1 | [sllidar_node-1] [INFO] [1674160896.810386715] [sllidar_node]: SLLidar S/N: 5086EDF9C7E29BD1A7E39EF2C055431B
rosbot-bringup-rplidar-1 | [sllidar_node-1] [INFO] [1674160896.810586139] [sllidar_node]: Firmware Ver: 1.28
rosbot-bringup-rplidar-1 | [sllidar_node-1] [INFO] [1674160896.810635658] [sllidar_node]: Hardware Rev: 7
rosbot-bringup-rplidar-1 | [sllidar_node-1] [INFO] [1674160896.861995824] [sllidar_node]: SLLidar health status : 0
rosbot-bringup-rplidar-1 | [sllidar_node-1] [INFO] [1674160896.862198860] [sllidar_node]: SLLidar health status : OK.
rosbot-bringup-rplidar-1 | [sllidar_node-1] [INFO] [1674160897.408425324] [sllidar_node]: current scan mode: Standard, sample rate: 2 Khz, max_distance: 16.0 m, scan frequency:10.0 Hz,
rosbot-bringup-rosbot-1 | [INFO] [robot_state_publisher-1]: process started with pid [60]
rosbot-bringup-rosbot-1 | [INFO] [ros2_control_node-2]: process started with pid [62]
rosbot-bringup-rosbot-1 | [INFO] [ekf_node-3]: process started with pid [64]
rosbot-bringup-rosbot-1 | [INFO] [spawner-4]: process started with pid [66]
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link body_link had 11 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link camera_link had 1 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link orbbec_astra_link had 1 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link orbbec_astra_depth_link had 1 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link orbbec_astra_depth_reference_link had 0 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link cover_link had 1 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link rplidar_a2_link had 1 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link laser had 0 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link imu_link had 0 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link fl_range had 0 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link fl_wheel_link had 0 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link fr_range had 0 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link fr_wheel_link had 0 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link rl_range had 0 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link rl_wheel_link had 0 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link rr_range had 0 children
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] Link rr_wheel_link had 0 children
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.615799986] [resource_manager]: Loading hardware ‘imu’
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.634821592] [resource_manager]: Initialize hardware ‘imu’
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.634968312] [RosbotImuSensor]: Initializing
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.616258371] [robot_state_publisher]: got segment base_link
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.617531118] [robot_state_publisher]: got segment body_link
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.617646599] [robot_state_publisher]: got segment camera_link
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.617685691] [robot_state_publisher]: got segment cover_link
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.617717580] [robot_state_publisher]: got segment fl_range
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.617746191] [robot_state_publisher]: got segment fl_wheel_link
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.617774598] [robot_state_publisher]: got segment fr_range
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.617802190] [robot_state_publisher]: got segment fr_wheel_link
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.617829912] [robot_state_publisher]: got segment imu_link
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.617856838] [robot_state_publisher]: got segment laser
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.617883319] [robot_state_publisher]: got segment orbbec_astra_depth_link
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.617910726] [robot_state_publisher]: got segment orbbec_astra_depth_reference_link
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.617939133] [robot_state_publisher]: got segment orbbec_astra_link
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.617966022] [robot_state_publisher]: got segment rl_range
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.617992873] [robot_state_publisher]: got segment rl_wheel_link
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.618020299] [robot_state_publisher]: got segment rplidar_a2_link
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.618048151] [robot_state_publisher]: got segment rr_range
rosbot-bringup-rosbot-1 | [robot_state_publisher-1] [INFO] [1674160898.618075039] [robot_state_publisher]: got segment rr_wheel_link
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.751824588] [resource_manager]: Successful initialization of hardware ‘imu’
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.752225770] [resource_manager]: Loading hardware ‘wheels’
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.753269501] [resource_manager]: Initialize hardware ‘wheels’
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.753456296] [RosbotSystem]: Initializing
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.753787052] [RosbotSystem]: Joint ‘fl_wheel_joint’ found
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.754029457] [RosbotSystem]: Joint ‘fr_wheel_joint’ found
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.754138586] [RosbotSystem]: Joint ‘rl_wheel_joint’ found
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.754177271] [RosbotSystem]: Joint ‘rr_wheel_joint’ found
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.804752165] [resource_manager]: Successful initialization of hardware ‘wheels’
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.805307086] [resource_manager]: ‘configure’ hardware ‘imu’
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.805396585] [RosbotImuSensor]: Configuring
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.805427474] [resource_manager]: Successful ‘configure’ of hardware ‘imu’
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.805456307] [resource_manager]: ‘activate’ hardware ‘imu’
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160898.805478899] [RosbotImuSensor]: Activating
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [WARN] [1674160898.822775965] [RosbotImuSensor]: Feedback message from imu wasn’t received yet
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [WARN] [1674160899.323068483] [RosbotImuSensor]: Feedback message from imu wasn’t received yet
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160899.323266333] [resource_manager]: Successful ‘activate’ of hardware ‘imu’
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160899.323329332] [resource_manager]: ‘configure’ hardware ‘wheels’
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160899.323359054] [RosbotSystem]: Configuring
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160899.323382962] [resource_manager]: Successful ‘configure’ of hardware ‘wheels’
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160899.323415202] [resource_manager]: ‘activate’ hardware ‘wheels’
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160899.323437461] [RosbotSystem]: Activating
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [WARN] [1674160899.344813120] [RosbotSystem]: Feedback message from motors wasn’t received yet
rosbot-bringup-rosbot-1 | [spawner-4] [INFO] [1674160899.581904610] [spawner_joint_state_broadcaster]: Waiting for ‘/controller_manager’ services to be available
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [WARN] [1674160899.845058106] [RosbotSystem]: Feedback message from motors wasn’t received yet
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160899.845209642] [resource_manager]: Successful ‘activate’ of hardware ‘wheels’
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160899.891975146] [controller_manager]: update rate is 20 Hz
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160899.895527781] [controller_manager]: RT kernel is recommended for better performance
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160900.035816034] [controller_manager]: Loading controller ‘joint_state_broadcaster’
rosbot-bringup-rosbot-1 | [spawner-4] [INFO] [1674160900.101663183] [spawner_joint_state_broadcaster]: Loaded joint_state_broadcaster
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160900.110987821] [controller_manager]: Configuring controller ‘joint_state_broadcaster’
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160900.111401077] [joint_state_broadcaster]: ‘joints’ or ‘interfaces’ parameter is empty. All available state interfaces will be published
rosbot-bringup-rosbot-1 | [spawner-4] [INFO] [1674160900.202394258] [spawner_joint_state_broadcaster]: Configured and activated joint_state_broadcaster
rosbot-bringup-rosbot-1 | [INFO] [spawner-4]: process has finished cleanly [pid 66]
rosbot-bringup-rosbot-1 | [INFO] [spawner-5]: process started with pid [124]
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160901.209652239] [controller_manager]: Loading controller ‘rosbot_base_controller’
rosbot-bringup-rosbot-1 | [spawner-5] [INFO] [1674160901.425312694] [spawner_rosbot_base_controller]: Loaded rosbot_base_controller
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160901.432754534] [controller_manager]: Configuring controller ‘rosbot_base_controller’
rosbot-bringup-rosbot-1 | [spawner-5] [INFO] [1674160901.602151793] [spawner_rosbot_base_controller]: Configured and activated rosbot_base_controller
rosbot-bringup-rosbot-1 | [INFO] [spawner-5]: process has finished cleanly [pid 124]
rosbot-bringup-rosbot-1 | [INFO] [spawner-6]: process started with pid [138]
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160902.784197248] [controller_manager]: Loading controller ‘imu_broadcaster’
rosbot-bringup-rosbot-1 | [spawner-6] [INFO] [1674160902.922581344] [spawner_imu_broadcaster]: Loaded imu_broadcaster
rosbot-bringup-rosbot-1 | [ros2_control_node-2] [INFO] [1674160902.929728187] [controller_manager]: Configuring controller ‘imu_broadcaster’
rosbot-bringup-rosbot-1 | [spawner-6] [INFO] [1674160903.054748200] [spawner_imu_broadcaster]: Configured and activated imu_broadcaster
rosbot-bringup-rosbot-1 | [INFO] [spawner-6]: process has finished cleanly [pid 138]

ON THE HOST PC
jcoco@lemurpro:~$ ros2 topic echo /scan
header:
stamp:
sec: 1674161499
nanosec: 427968503
frame_id: laser
angle_min: -3.1241390705108643
angle_max: 3.1415927410125732
angle_increment: 0.01745329238474369
time_increment: 0.0003178311453666538
scan_time: 0.11410138010978699
range_min: 0.15000000596046448
range_max: 16.0
ranges:

  • .inf

  • 0.12925000488758087

  • 0.12925000488758087

  • .inf

  • 0.12925000488758087

  • .inf

  • 0.12974999845027924

  • .inf

  • 0.13050000369548798

  • .inf

  • 0.13124999403953552

  • .inf

  • 0.13300000131130219

  • .inf

  • 0.1354999989271164

  • .inf

  • 0.1392499953508377

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • .inf

  • 0.15199999511241913

  • .inf

  • 0.15125000476837158

  • .inf

  • 0.1509999930858612

  • .inf

  • 0.1509999930858612

  • .inf

  • 0.15074999630451202

  • .inf

  • 0.1509999930858612

  • .inf

  • 0.15125000476837158

  • .inf

  • 0.15174999833106995

  • .inf

  • 0.1525000035762787

  • .inf

  • 0.1535000056028366

  • .inf

  • 0.1547500044107437

  • .inf

  • 0.15600000321865082

  • .inf

  • 0.1577499955892563

  • .inf

  • 0.15974999964237213

  • 0.16200000047683716

  • .inf

  • 0.16425000131130219

  • .inf

  • 0.16725000739097595

  • .inf

  • 0.1704999953508377

  • .inf

  • 0.17374999821186066

  • .inf

  • .inf

  • 0.17749999463558197

  • .inf

  • 0.18174999952316284

  • .inf

  • ‘…’
    intensities:

  • 0.0

  • 15.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • 0.0

  • 15.0

  • 0.0

  • 15.0

  • 0.0

  • ‘…’


I also show the terminal output of the scan. Any suggestions would be appreciated.
My ROSbot2R is sitting on a table within close proximity to an object in front of it and to it’s left. Open space behind and to the right.

Joe


The first image is from the real robot. The second image is from the simulation. Striking difference made me stand up and notice.

Hello @Joe_Worthit

how do you launch this example with “real” robot?

Best regards
Jan Brzyk

      docker compose -f compose.rosbot.yaml up

From the rosbot-mapping directory on the “real” robot, I entered the command and it produced the output described above.

Pulled from rosbot-mapping. Unfortunately, no modifications were made. Just ran it. I accepted the result as being normal. Navigating was difficult. It looked like the “real” robot couldn’t find the goal. Now I know why.

compose.rosbot.yaml

services:

rosbot:
image: husarion/rosbot:humble-22-12-08
network_mode: host
ipc: host
environment:
- DDS_CONFIG
- RMW_IMPLEMENTATION
command: ros2 launch rosbot_bringup rosbot_bringup.launch.py

microros:
image: husarion/micro-ros-agent:humble-22-12-07
network_mode: host
ipc: host
devices:
- ${SERIAL_PORT:?err}
environment:
- DDS_CONFIG
- RMW_IMPLEMENTATION=rmw_fastrtps_cpp
command: ros2 run micro_ros_agent micro_ros_agent serial -D $SERIAL_PORT serial -b 576000 # -v6

rplidar:
image: husarion/rplidar:humble
restart: unless-stopped
network_mode: host
ipc: host
devices:
- /dev/ttyUSB0
environment:
- ROS_DOMAIN_ID=${ROS_DOMAIN_ID:-0}
- RMW_IMPLEMENTATION=${RMW_IMPLEMENTATION:-rmw_fastrtps_cpp}
command: >
ros2 launch sllidar_ros2 sllidar_launch.py serial_baudrate:=${RPLIDAR_BAUDRATE:-115200}

mapping:
image: husarion/slam-toolbox:humble-22-12-07
network_mode: host
ipc: host
volumes:
- ./config/slam_toolbox_params.yaml:/slam_params.yaml
environment:
- DDS_CONFIG
- RMW_IMPLEMENTATION
command: >
ros2 launch slam_toolbox online_sync_launch.py
slam_params_file:=/slam_params.yaml
use_sim_time:=False

compose.pc.yaml

services:

map-saver:
image: husarion/nav2-map-server:humble-22-12-07
network_mode: host
ipc: host
volumes:
- ./maps:/maps
environment:
- DDS_CONFIG
- RMW_IMPLEMENTATION
command: bash -c “while true; do ros2 run nav2_map_server map_saver_cli --free 0.15 --fmt png -f /maps/map; sleep 5; done”

rviz:
image: husarion/rviz2:humble-22-12-08
network_mode: host
ipc: host
volumes:
- /tmp/.X11-unix:/tmp/.X11-unix:rw
- ./config/rosbot.rviz:/root/.rviz2/default.rviz
environment:
- DDS_CONFIG
- RMW_IMPLEMENTATION
- DISPLAY=${DISPLAY:?err}
- LIBGL_ALWAYS_SOFTWARE=1

joy2twist:
image: husarion/joy2twist:humble-22-12-07
network_mode: host
ipc: host
devices:
- /dev/input
volumes:
- ./config/joy2twist.yaml:/joy2twist.yaml
environment:
- DDS_CONFIG
- RMW_IMPLEMENTATION
command: >
ros2 launch joy2twist gamepad_controller.launch.py
joy2twist_params_file:=/joy2twist.yaml

FIRMWARE

docker stop rosbot microros || true && docker run --rm -it --privileged husarion/rosbot:humble-22-12-08 /flash-firmware.py /root/firmware.bin

Hello @Joe_Worthit,

try to modify the .env file with nano .env being in rosbot-mapping directory.

  1. Comment this line: RMW_IMPLEMENTATION=rmw_fastrtps_cpp

  2. Uncomment this line: # RMW_IMPLEMENTATION=rmw_cyclonedds_cpp

  3. If you use sync_with_rosbot.sh script the changes will be also done in ROSbot’s .env file. But (according to its content) you will also have to run export RMW_IMPLEMENTATION=rmw_cyclonedds_cpp in the ROSbot terminal

Then the problem should be solved. rosbot-navigation should behave better also with this change.

Best regards
Jan Brzyk

Thanks for your suggestion. I made the edits to the .env file and used the sync script. Ensured export on the ROSbot2R. Ensured the .env file matched.
The resulting launch generated the same output. Rviz had no change and the majority of the scan readings are still inf.

Please, make sure that the RMW_IMPLEMENTATION variable is set properly on both PC and ROSbot.

echo $RMW_IMPLEMENTATION

Best regards
Jan Brzyk

Yeah, well I certainly did that before I replied. Thanks for all your support but I guess we just couldn’t get it to work. I must sell it here or on eBay.

I had a nice chat with the AI on openai.com(GPT3). The AI concluded my scan parameters are likely at fault. The recommendation is to ensure the parameters are set correctly.

I am assuming these scan parameters are built in to the docker service for rplidar in a the configuration file it uses but, I don’t know how to check or modify them. I can’t seem to get the sllidar_ros2 to run without a bunch of statically defined parameters not being initialized. So much for THAT code.

Perhaps I should chat with my AI friend about Husarion ROSbot2R robots. I was impressed and feel I haven’t scratched the surface of it’s knowledge. It takes clever questions to get the answers you need. Cool!