Off costmap error

Hi. I have my Rosbot 2.0 pro running with webgui then I am connecting Rviz to send 2D goals. It is moving OK and building a map, but I am only able to move very short distances. If I try and move much more than about 2 meters it just reports:

The goal sent to the navfn planner is off the global costmap. Planning will always fail to this goal

then starts spinning around lost.

I have tried editing the costmap paramaters in the local and global conf files, but it then just seems to run into the walls - so I assume I am editing the wrong params.

What paramaters in what file should I edit to allow setting 2D goals that are further away? What is the consequence of setting this too far away?

BTW … I am always getting warnings that the servo rate is not meeting target so I guess it is getting a bit loaded?


Hi Barry,

I checked your problem on ROSbot and I can not reproduce it. Can you provide me more information. Do you use default parameters configuration? Which command do you use to launch system? Log files and parameters of created costmaps (for example from rviz).

Please give me every information which can help me to reproduce your issue.

Best regards,

I think i have solved it.

I was changing both the local and global costmap paramaters. It seems if i leave the local costmap width and height at 3m I can increase the global width and height and now I can set goals further away.

It seems setting the local costmap at 5 instead of 3 and he runs into the walls! Doesn’t really make sense - but I will take it!