Panther: Problem with finding the wifi and control the robot

Hi again! I hope you guys are doing fine. My teammates encountered a problem setting up the Panther, especially when using the above instructions in the image. Wifi cannot be found. Thus, they could not control the robot with web UI and just saw the power on. Is there something that we are missing?

This is the message from one of my teammates:

On the husarion web they say you can connect and control the panther via wifi without coding.
However, we cant find the wifi in our available networks. 

I also opened the port 22 in my firewall but still no wifi visible. 
Also when the usb plugged in for the controller, the panther
 only responds to the e-stop button. Its not moving when controller used.

Hello @Ton_Hoang_Nguyen,

Regarding the joystick, you may need to remap the topic, e.g. from /cmd_vel to /panther/cmd_vel.

To confirm this, it is best to use the ros2 topic list tool and check whether there are two /cmd_vel topic with different namespace. You can do the remapping in the composie file in the line with command:

I still have no idea where the WiFi problem could be. Please provide:

  1. Serial number (S/N)
  2. Did the problem occur after reinstalling the system from ROS 1 to ROS 2?
  3. Was there a moment when Wi-Fi worked? If so, what actions were performed?
  4. What’s going on with the LEDs on the bumpers?

Best regards,
Husarion Team

Hi @RafalGorecki,

I am the team mate of @Ton_Hoang_Nguyen and we were setting up the Panther. To answer your questions :-

  1. The serial number is 0e9b.

  2. The problem did not occur after reinstalling the system from ROS 1 to ROS 2. The problem occurred right after we unboxed it and were powering on for the first time.

  3. We followed the instructions in the manual and couldn’t get the signal anywhere (Laptop,phone), not even for a brief moment. We tried to manually add the network, but it didn’t work. We saw the led indicator (bumper lights) indicating low battery so we figured it was because of the low battery. Then the next day we charged it and tried again all the steps above, still it wasn’t detecting wifi.

  4. They work fine, with the controller we were able to trigger e-stop as well, it changed to green lights indicating ready to move but on moving the joystick it did not move.

If there is anything that we need to do, let us know. We think that the problem might be in the router, could you also provide us the username/password of the built in router If its possible? Looking forward to your response.

Kind regards,
Qafka team

1 Like

Hello @Jimeet_Oza,

Thank you for your answer, I will let you know about WiFi tomorrow.

For joystick control, please do:

  1. Stop the docker processes.
docker compose down
  1. Replace compose.yaml to the latest version: panther-docker/demo/compose.minimal-setup.yaml at ros2 · husarion/panther-docker · GitHub

  2. Run composes.

docker compose up

Please let me know if you have managed to control the joystick yet.

1 Like

Hello @RafalGorecki,

Thanks for the instructions! The Wi-Fi is working now as we changed the region from United States to The Netherlands. We found it in the router settings page when we were troubleshooting. Don’t know the exact reason why it started working after we changed the region but it might be due to different sub bands that regions operate in.

We were also able to use the joystick, and robot is able to move.

Kind regards,
Qafka Team.

Hello @Jimeet_Oza,

I’m glad you managed to solve the problem, especially since it’s not an error I’ve encountered personally. I hope the robot will no longer cause problems. If you notice anything that you think could be improved, please let us know so that we can gradually develop the platform.

I would also like to ask you to confirm whether the joystick also works.