Panther ROS2 Updating Motor firmware


With @Brayden_RMIT , we’re updating Panther to ROS2. We’re also having troubles with the Firmware update of the motor controllers.

Following the instructions here where getting stuck with the DFU firmware upload. We can read from the controller successfully. However, when I try to “Update Firmware via USB”, the controller goes into DFU mode, but fails to restart. So I get the window, but I can’t select the DFU update. See image. The same issue occurs if I use update via COM.
(For reference we are powering on the motors using the ROS2 launch, not direct power as we don’t want to disconnect the wiring)

Do you have suggestions? Trying to find an answer on the RoboPlus website hasn’t found any answers.

Thank you.

Just a a bit of a follow-on, when I use the COM3 port, I get the following error output

Checking file: \\...\SBL2XXX-Firmware-Update-v21a-051923\SBL2XXX-Firmware-Update-v21a-051923.bin

Searching for device...
Checking COM3...device not found.


Sorry to add further to this.
I think that the ROS1/ROS2 nodes controlling the moroto boards are causing conflicts with what the RoboRun+ software wishes to do. That is, the motor boards are constantly being turned off by other software. The controller board is now in a poor state. Is there a way to just power on the motor controller without the ROS software?


Hello @Tim_RMIT,

Power supply
You can use the following commands to power the motors:

  1. sudo pth_hw update_config (one-time command)
  2. pth_motors_on.


  1. In the Console tab:
  2. Click Update Firmware via USB
  3. Once the drivers are installed and the target device is visible
  4. Select the firmware file (version v2.1a) by clicking Choose
  5. After successfully uploading the file, click Upgrade to upload the new firmware

If you don’t see a device, the driver for Windows is probably not being installed. Make sure you have internet access, if that doesn’t help, try manually installing the DFU controller.


  • whether the motors are powered
  • do not duplicate the power supply from ROS and the pth_motors_on script

Let me know about results.

Hello @RafalGorecki,

Thanks for getting back to us with these instructions/suggestions.

I think my key follow-up question is if there is a non-windows option? Trying to get a windows machine to work is proving troublesome.

  • I run Mac (M1)/linux (arm64). I have a WIndows 11 VM that works within My mac. Thus, given your instructions, I think the reason that I can’t see the DFU controller option in the “flash firmware” option is because there is no DFU driver compatible with W11 and arm64. I have tried manually installing the DFU drivers and can’t find a compatible driver. So I think that’s why no driver was downloaded automatically.
  • I have tried using a university provided Windows Machine, however, the university policies are playing havoc with the RoboRun+ software and preventing the installation/use of the software. I’m trying to sort out a solution but it’s slow.

Regardless, for now I’m going to have to park this until the end of semester as go with the ROS1 setup.

Thank you for your help.

Hello @Tim_RMIT,

Unfortunately, the Roborun+ application is only available for Windows.

I see that there are 5 articles on the Roboteq website that expand on the DFU topic. Perhaps one of the available solutions will also be helpful in your case.

If any of these articles help, you can help other users by sharing your solution with the community.

In my free time I will try to reproduce your problem using WIndows 11 VM.


Hello @RafalGorecki ,

Thanks for getting back. That’s a shame.

For the VM I think it’s more likely because it’s on an M1 (arm64) machine. not the Windows 11 part.