Problem getting new Rosbot2 Pro to run with ros2 image


we are trying to set up the Rosbot2 Pro with a ROS2 Image by following the tutorial on the hussarion hompage. But this does not seem to work, the command

ros2 daemon stop

gives an error. See also this screenshot:

Did anyone else have this problem or does anyone have a solution?


Hello @danielKleissl

On a new, clean ROSbot 2 PRO image with ROS 2 natively installed, everything should work fine. You should then have ROS 2 Foxy installed.

Check the contents of the /opt/ros/ folder with the following command:

ls /opt/ros/

If the foxy folder is there, try the following command:

source /opt/ros/foxy/setup.bash

If now, commands starting with ros2 still don’t work - let me know here.

Best regards
Jan Brzyk

Hello Jan,

here is a screenshot of my opt/ros folder, new rosbot 2 pro:

As you can see there is no ros foxy installed.

But I am starting to suspect that the documentation is plain wrong. The tutorial I followed are missing the steps to enter the running docker container. Without that there should be no way to access ros2 running inside the container from outside, if I understand docker correctly.

At the moment we are running into an error when trying to start the rosbot_mapping docker on the robot.

Invalid interpolation format for services.microros.devices.[]: "required variable SERIAL_PORT is missing a value: err". You may need to escape any $ with another $.

We tried adding a second $ as suggested by the error but then we get the error message:

Attaching to rosbot-mapping-mapping-1, rosbot-mapping-microros-1, rosbot-mapping-rosbot-1, rosbot-mapping-rplidar-1 Error response from daemon: error gathering device information while adding custom device "${SERIAL_PORT": no such file or directory

Can you assist with this problem?

Edit 1: We got somewhat further, found the right serial port variable in the documentation. But still rviz does not show the robot (see screenshot). What else could be going wrong?

We tried installing a new ubuntu foxy image according to the tutorial on the husarion homepage. Now foxy is available on the bot, but the error is basically the same as above…

Hello @danielKleissl

I was going to write that you have OS Image with ROS Melodic, which is a setup that is no longer supported. But if you actually flashed the new OS Image from ROS2 Foxy according to this tutorial, you should be fine. Did you went through How to Start for ROSbot 2 PRO selecting tabs for ROS2?

Best regards
Jan Brzyk

I did, but we suspect our network is to blame. We connected the robot via our official university network but did not consider what messages publishers and subscribers exchange.

If I know right, these should be multicast/broadcast messages, and the network might very well block these… We will try to make a network using a mobile phone as a router when I am at the lab on Friday until we get a router for the laboratory. I asked in some other communities, and this seems to be a known problem with ROS… I will let you know how it went.


Ok, let me know about the results.

Best regards
Jan Brzyk