Problem uploading to board

I’m using a core2 with a rpi3, but now if I try to upload the “how to start” code, I’m getting the error: “programming error (invalid bin file)”. It worked fine at first but then I think I aborted an upload and it wouldn’t work anymore. So tried to relink the board and also tried a rpi3 os reimage. But no succes there.

Hi Ruben_Hoebee.

We are working to fix this problem. You just have to go back to your robot list and turn on IDE one more time. After that everything should work fine.


Hi, another Question, same Topic:
Same Problem here. As Workaround I used my STLinkV2 with ST-Utilities to Upload the hex-file.

I’m not so deep in STM32, so have I to upload some kind of Bootloader if I want to use the IDE again ?


Hi Souko,

yes, you need to upload a bootloader, which has a reserved space in memory - from 0x08000000. The user programs starts at 0x08010000. If you overwrite or corrupt the bootloader, you will not be able to upload user program using USB serial connection.

Here is the guide how to upload a new bootloader to CORE2:

Please check if it works for you.


hi, in recent days I´ve been having problems while trying to connect CORE2+ROS to the cloud, uploading code by using the cloud IDE, I’m also unable to update the board bootloader or esp firmware (by following the steps published on the website) it says “connecting to bootloader…UNABLE (restarting)”. Before that I had no problems with my board except for the serial communication problem refered to ros serial node. I’m using RPi3 with my husarion boards (this means the problem is not isolated, because I’m using 3 boards). Please HELP ME! I’m attempting to finish my PhD thesis this year!