Rosbot 2.0 Pro Range sensors / Time of flight randomly stop working


I’ve been working with the Rosbot 2.0 Pro, but I’m encountering an issue with the 4 range sensors (the time of flight sensors).
I launch the rplidar and the rosbot_ekf (all.launch) and it works fine for a while, but then some of the range sensors start publishing -1 values for their range aspect; such as the following:

  seq: 2843
    secs: 1578568817
    nsecs: 112711009
  frame_id: ''
radiation_type: 1
field_of_view: 0.259999990463
min_range: 0.0299999993294
max_range: 0.899999976158
range: -1.0

So far it’s been the front left, front right, and rear right. Restarting the rosbot_ekf node doesn’t help. Fully turning the Rosbot off and on again, then restarting the nodes does fix the problem.

I have no clue why it happens, sometimes it’s within minutes of start up, sometimes everything is still fine after 30+ minutes.

What could be the issue and how can this be solved?


Thank you for reporting the problem. We will investigate it and issue the fix as soon as possible.

The sensors are initialized after the power cycle/reset so pushing the reset button should help. You don’t need to turn ROSbot off and on again.

Sorry for the inconveniences.

Kind Regards,

Hi Szymon,

Thank you for your reply and the tip. That should save some time when encountering the error.

I’m looking forward to the fix, I wish you good luck :slight_smile:

Kind regards,

Hi Szymon,

I am experiencing the same problem with the Rosbot 2.0. Is it also possible to do a software reset? I.E:
As a temporary solution until this is fixed?


Hi Patrick,

Could you check if the problem persists after turning the distance sensors of and on again by running

rosservice call /config “command: ‘EDSE’ data: ‘0’”

rosservice call /config “command: ‘EDSE’ data: ‘1’”


Hi Szymon @byq77,

Do you have any updates on this bug? Using the service call to turn the sensors of and on again does not resolve the bug. Indeed, resetting the CORE2 with the button works, but I was hoping for a real solution.



Yes the update is ready. Sorry that it took so long. We will update the docs soon, but at the moment here are the links to new firmware binaries:

The sensors lib implementation was improved, the publication rate on sensors topic was increased to 10Hz and automatic restart mechanism was added in case of sensors malfunction/i2c error. For more details please look up the project’s changelog on GitHub.

The problem seems to be solved, but I need more tests to be 100% sure. I would very much appreciate your feedback.



It is working for most ROSbots, however two are giving an error initializing the range sensors when running the core2ros serial node.
Also one still gave the range sensor error under the new firmware.