ROSbot 2.0 simulation with gazebo on ready VM fails

I have downloaded the ready to use virtual machine for ROSbot 2.0 simulation with gazebo but it fails as attached below

the failure is on a quite powerful windows 10 laptop
4 cores and 11GB dedicated to the virtual machine

husarion@husarion:~/ros_workspace$ source devel/
husarion@husarion:~/ros_workspace$ roslaunch rosbot_description rosbot.launch

[ INFO] [1573838800.008258320]: Finished loading Gazebo ROS API Plugin.
[ INFO] [1573838800.009749580]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting…
SpawnModel script started
Segmentation fault
Segmentation fault
[gazebo-5] process has died [pid 2320, exit code 139, cmd /opt/ros/kinetic/lib/gazebo_ros/gzserver -e ode /home/husarion/ros_workspace/src/rosbot_description/src/rosbot_gazebo/worlds/ __name:=gazebo __log:=/home/husarion/.ros/log/14540ebe-07cd-11ea-96a8-0800271aea27/gazebo-5.log].
log file: /home/husarion/.ros/log/14540ebe-07cd-11ea-96a8-0800271aea27/gazebo-5.log*
[gazebo_gui-6] process has died [pid 2346, exit code 139, cmd /opt/ros/kinetic/lib/gazebo_ros/gzclient __name:=gazebo_gui __log:=/home/husarion/.ros/log/14540ebe-07cd-11ea-96a8-0800271aea27/gazebo_gui-6.log].
log file: /home/husarion/.ros/log/14540ebe-07cd-11ea-96a8-0800271aea27/gazebo_gui-6.log*
[INFO] [1573838800.291664, 0.000000]: Loading model XML from ros parameter
[INFO] [1573838800.299453, 0.000000]: Waiting for service /gazebo/spawn_urdf_model

^C[robot_state_publisher-4] killing on exit
[rosbot_spawn-3] killing on exit
[joint_state_controller_spawner-2] killing on exit
[WARN] [1573838817.768136, 0.000000]: Controller Spawner couldn’t find the expected controller_manager ROS interface.
Traceback (most recent call last):
File “/opt/ros/kinetic/lib/gazebo_ros/spawn_model”, line 313, in
File “/opt/ros/kinetic/lib/gazebo_ros/spawn_model”, line 271, in callSpawnService
initial_pose, self.reference_frame, self.gazebo_namespace)
File “/opt/ros/kinetic/lib/python2.7/dist-packages/gazebo_ros/”, line 28, in spawn_urdf_model_client
File “/opt/ros/kinetic/lib/python2.7/dist-packages/rospy/impl/”, line 159, in wait_for_service
raise ROSInterruptException(“rospy shutdown”)
rospy.exceptions.ROSInterruptException: rospy shutdown
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor…
… shutting down processing monitor complete

Hi Alessio_Stella,

I’ve check working of our VM image with rosbot_description pkg and everything seems to work OK. Did you change
amount of Video Memory? I remember that in default setting value is very small and can cause such errors. I can’t be sure if this one is one of them but please check it.

You should also remember to use:

sudo apt update
sudo apt dist-upgrade

to make sure that all packages are up to date.

Please let me know the results.

Best regards,

Dear Hubert

thanks a lot for the support. I have managed to run the machine and the gazebo simulation of the robot successfully on another desktop pc. While on the laptop where I originally run the machine, the virtual machine seemed to be working fine, but even following carefully the tutorial i ran into that mentioned malfunctioning (no gazebo simulation up and running). I tried to change settings increasing resources but no solution. I will more investigate and let you know the results. Now i don’t have the laptop with me so i cannot specifiy much the details of the machine. Thanks again

1 Like