ROSbot unable to start moving

I have copied the tutorial Simple kinematics and visualization | Husarion to get my rosbot to start moving using the keyboard but it isn’t working. I have tried
docker compose up -d rosbot ros-master
rosrun teleop_twist_keyboard
and it did not work, despite the having the correct output on the screen, however the second command worked to control the virtual robot in gazebo.
I then got the error message Waiting for subscriber to connect to /cmd_vel, which I seemed to fix by running rostopic echo /cmd_vel in another terminal. I can see that the values of the axis change when I press the control buttons on the keyboard but the actual rosbot does not move.
I have tried roslaunch rosbot_ekf all.launch, ./ and sudo apt-get install ros-melodic-robot-localization but nothing has worked.

The problem has been fixed by running roslaunch rosbot_ekf rosserial_bridge.launch serial_port:=/dev/ttyS4 serial_baudrate:=520000 which allows me to control the rosbot.
However, now the /odom topic has not been published and that is needed for the next part of the tutorial.

Hello @daisy and welcome to the Husarion Community!

What model of robot are you using?

Best regards
Jan Brzyk

Hi @JanBrzyk

I think I have solved my problem, thank you.

Hi @daisy
I’m glad to hear that! Could you share your solution? Maybe in the future someone from Husarion Community will encounter a similar problem.

Best regards
Jan Brzyk