[Solved] Can't find Raspberry Image for Humble

is there an image for Raspberry Pi to use with the ROS2 version of the “rosbot-stm32-firmware”- ros2 branch?
As far as I understand it is configured for Humble, but I can only find an image for Galactic of Foxy at the download page https://husarion.com/downloads/



Hi MichaelT,

I’m sorry, but we don’t have any image for RPi 3 with ROS2. ROS2 is suited only for 64 bits CPU architecture, so if you would like to use ROS2 on 32 bits system, it will be necessary to build everything from source. We strongly advise against such solutions, as it is a torment. The best way to switch from ROS1 to ROS2 would be changing SBC for RPi 4B / Up Board or something similar.

Best regards,

Hi Hubert,

thanks for your quick response.
I forgot to mention, that I have a RPi 4B, but the images I found at your downloads were only for Foxy and Galactic, not for Humble …


You are right, we don’t have image with Humble distro yet. I can’t tell you when can you expect release, but I can assure you that we’re already working on it.

Best regards,

Ok, thanks, I will wait :wink:


1 Like

The new SBC image for Humble is available for download now. I retrieved it and flashed the firmware on my ROSbot2R.
docker stop rosbot microros || true && docker run --rm -it --privileged husarion/rosbot:humble /flash-firmware.py /root/firmware.bin

The docker compose pull went cleanly and pulled

Then I ran
docker compose up -d rosbot microros

The containers were created and started. However, when I ran ros2 topic list, all I saw was
…no list of topics as in the Quick Start tutorial. Upon further analysis, it would appear I only receive the full list of topics the first time the containers are brought up. Thereafter, bringing them down then back up produces the abbreviated list. A reboot is required to get the topics I expect back again.


that’s good news.
Where can I find the image? There is nothing at the downloads page.


LOL. Yeah, it’s hidden quite well.

Thanks for the info