[Solved] Can't register rosbot 2.0 device to cloud Husarion

Hi,

I’m using Rosbot 2.0 and I can’t add/register my rosbot to cloud husarion. I already tried all tutorial (using hConfig app, website, via ssh) but the result still same. I checked some similar problem here in community and tried the solution, but my device still not appear in my cloud account.

Another thing is LR2 (blue) LED keep flashing. I still can connect to my rosbot via ssh and RDP.

Is there any same issue here that i might missed, or is there any solution for this problem?

Thanks.

Hi,
Sometimes my rosbot was diappeared from the cloud and I need to redo the appearing procedure but since today I’ve got the same issue as you, my rosbot still offline.
Is there a problem with the Husarion Cloud ?

Thanks,

Hello,

We had a problem with server, the issue is solved now. You can connect your device to cloud.

Also I would like to notice, that we are switching framework for ROSbots to MBED. The cloud IDE and hFramework will be still supported but they are not recommended for new projects.

New firmware can be developed with VSCode. In case you want to be able to program firmware for ROSbots remotely, you should use Husarnet.

Regards,
Łukasz

Hello Łukasz,
Thank you for your answer.
Can you please explaine to me what is the interest to switch on your new MBED framework ?
I ask because I consumed a lot of time to improve my rosbot functionality based on hFramework, it’s not perfect but it works. So, before to spend again many time to appropriate me your new framework based on MBED , can you please give me the major interests of this new framework ?

Regards,
Baptiste

Hi Baptiste

the same applies to me. I had a similar question in the forum: https://community.husarion.com/t/hframework-vs-mbed-os/733
Can you move your question about mbed to a new topic to make it better findable?

Michael

Hello Baptiste,

If you have your project already developed and it meets all your requirements, you will not notice any improvement form switching to MBED, thus there is no significant reason to switch.

On the other hand, if you are thinking of new project, then pros of switching to MBED are:

  • It has libraries available for many components, e.g. you can easily add support for sensors that are not available in hFramework
  • MBED is compatible with various boards and microcontrollers, thus once you learn MBED on ROSbot, you can reuse this knowledge in projects targeted on different platforms

Regards,
Łukasz

Thanks Łukasz for this pertinent point of view.

I had try to use your MBED firmware for my application, it seems effectively very nice for new application but in my case, I just need some tunning to finish my project and some sensors are not at all implemented like in hframework so I want to go back to the hframework with the Cloud programming.

My problem is that now my Rosbot is not connected to the Cloud… So I can’t recover my previous firmeware, it’s a big problem for me !
What I did is:
1/ Updating CORE2 bootloader: CORE2 | Husarion
2/ Reactivating the husarnet services

$ sudo systemctl enable husarion-shield
$ sudo systemctl start husarnet-configurator
$ sudo systemctl enable husarnet-configurator
$ sudo reboot

3/ Pairing my Rosbot with my cloud account

sudo husarion-register --code "prod|xxxxxxxxxxxxxxxxxxxxxx"
sudo systemctl restart husarnet-configurator

After that my Rosbot still offline. What is wrong ?

Thanks for support.
Baptiste

Hello Baptiste,

The service husarion-shield should not be enabled by user. It is controlled by husarnet-configurator when necessary.
Disable it again:

sudo systemctl disable husarion-shield
sudo reboot

Then try to register device again.

Regards,
Łukasz

Thank’s again, that was the problem.

Now I can see my Rosbot in the Cloud but unfortunately I’ve got a new issue when I buid my firmware (I tried with the Husarion standard one), on the terminal there is wrote:

Building…
Internal error
Build failed

Is there again a problem with Husarion Cloud ?

Regards,
Baptiste

Hi Baptiste,

I’m sorry for inconvenience this bug is also already fixed. Please try one more time.

Best regards,
Hubert

Hi lukasz.mitka,
Thanks for the answer on this topic. Now, I can register my device to cloud husarion.
I will add [Solved] to this topic.

Regards,
Nandika