[Solved] /dev/ttyCORE2 not found

When running /opt/husarion/tools/rpi-linux/ros-core2-client /dev/ttyCORE2, the tinkerboard is not connecting to the core2.

`[INFO] [1573139939.293622]: ROS Serial Python Node

[INFO] [1573139939.419126]: Connecting to /dev/ttyCORE2 at 500000 baud
[INFO] [1573139940.428961]: Connecting to /dev/ttyCORE2 at 500000 baud
[INFO] [1573139941.437563]: Connecting to /dev/ttyCORE2 at 500000 baud
[INFO] [1573139942.447830]: Connecting to /dev/ttyCORE2 at 500000 baud

ls /dev/ also does not show ttyCORE2

Power and L1 are both on (red).

Running other nodes like rplidar does work.

I did not flash the new firmware yet.


As suggested in another topic:
systemctl list-units --type service

  accounts-daemon.service            loaded active running Accounts Service
  avahi-daemon.service               loaded active running Avahi mDNS/DNS-SD Stack
  console-setup.service              loaded active exited  Set console font and keymap
  cron.service                       loaded active running Regular background program process
  dbus.service                       loaded active running D-Bus System Message Bus
  getty@tty1.service                 loaded active running Getty on tty1
  hostapd.service                    loaded active exited  LSB: Advanced IEEE 802.11 manageme
  husarnet-configurator.service      loaded active running Husarnet Configurator
  husarnet.service                   loaded active running Husarnet
  keyboard-setup.service             loaded active exited  Set console keymap
  kmod-static-nodes.service          loaded active exited  Create list of required static dev
  lightdm.service                    loaded active running Light Display Manager
  networking.service                 loaded active exited  Raise network interfaces
  NetworkManager.service             loaded active running Network Manager
  ondemand.service                   loaded active exited  LSB: Set the CPU Frequency Scaling
  polkitd.service                    loaded active running Authenticate and Authorize Users t
  rc-local.service                   loaded active exited  /etc/rc.local Compatibility
  resize-rootfs.service              loaded active exited  Resize the root filesystem
  resolvconf.service                 loaded active exited  Nameserver information manager
  rsyslog.service                    loaded active running System Logging Service
  rtkit-daemon.service               loaded active running RealtimeKit Scheduling Policy Serv
  setvtrgb.service                   loaded active exited  Set console scheme
  ssh.service                        loaded active running OpenBSD Secure Shell server
  systemd-fsck@dev-mmcblk0p1.service loaded active exited  File System Check on /dev/mmcblk0p
  systemd-journal-flush.service      loaded active exited  Flush Journal to Persistent Storag
  systemd-journald.service           loaded active running Journal Service
  systemd-logind.service             loaded active running Login Service
  systemd-modules-load.service       loaded active exited  Load Kernel Modules
  systemd-random-seed.service        loaded active exited  Load/Save Random Seed
  systemd-remount-fs.service         loaded active exited  Remount Root and Kernel File Syste
  systemd-sysctl.service             loaded active exited  Apply Kernel Variables
  systemd-timesyncd.service          loaded active running Network Time Synchronization
  systemd-tmpfiles-setup-dev.service loaded active exited  Create Static Device Nodes in /dev
  systemd-tmpfiles-setup.service     loaded active exited  Create Volatile Files and Director
  systemd-udev-trigger.service       loaded active exited  udev Coldplug all Devices
  systemd-udevd.service              loaded active running udev Kernel Device Manager
  systemd-update-utmp.service        loaded active exited  Update UTMP about System Boot/Shut
  systemd-user-sessions.service      loaded active exited  Permit User Sessions
  udisks2.service                    loaded active running Disk Manager
  upower.service                     loaded active running Daemon for power management
● ureadahead.service                 loaded failed failed  Read required files in advance
  user@1000.service                  loaded active running User Manager for UID 1000
  user@1001.service                  loaded active running User Manager for UID 1001
  wpa_supplicant.service             loaded active running WPA supplicant
  xrdp-sesman.service                loaded active running xrdp session manager
  xrdp.service                       loaded active running xrdp daemon

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.

46 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.```

Hi Lucasz/Hubert,

Could you help me with this? I am not able to use the ROSbot now.

Kind Regards,


Are you sure you have the rosbot 2.0 default firmware loaded to CORE2? Please log into your husarion cloud account, go to IDE, create new project and select the appropriate template:

In the IDE select build > build and then build > upload.

If it is able to flash the mcu, it should also connect with the ros-core2-client. Let me know if anything changed.


There indeed seemed to be a problem with the firmware not being loaded. I installed the new firmware and it is working now.



can you please share the fix because I am experiencing the same error.

As said by byq77, the ROSbot firmware was not loaded (correctly).

Following the steps in this tutorial fixed it for me.