[Solved] Error during launching tutorials

Hi, I get an error, when I try to launch tutorial_9 (also 6) on ROSbot:

error loading tag:
file does not exist [/rosbot_conf.yaml]
XML is
The traceback for the exception was written to the log file

I’ve found this topic, on the community site but it does not solve the issue.
I execute the command: export ROSBOT_VER=2.0.
Can anybody explain to me, where can I find missing yaml file, and how should it look like?


Hello Quarkpol,

The file rosbot_conf.yaml is used by rosbot_hardware.launch.
At first it is checked if ROSBOT_VER variable is set as 2.0 or 2.0_PRO. In case it is not found, file /rosbot_conf.yaml is used to get configuration parameters.

Variable ROSBOT_VER needs to be set in the same terminal window in which launch is used.

Content of /rosbot_conf.yaml depends on version, for ROSbot 2.0 use this one and for ROSbot 2.0 PRO use this one.


Hello, It’s been a while, but I had to come back to launch this tutorial again. I had the same error. I solved this problem and the solution is very simple. The correct command is export ROSBOT_VER=ROSBOT_2.0

1 Like