[Solved] Implementing Apriltag_ros

Hi I’m trying to use apriltag package. GitHub - AprilRobotics/apriltag_ros: A ROS wrapper of the AprilTag 3 visual fiducial detector
I was not able to catkin_make so I did catkin_make_isolated.

apriltag_ros/Tutorials/Bundle calibration - ROS Wiki When I tried to launch a tutorial I get the following error.
husarion@husarion:~/ros_workspace$ roslaunch apriltag_ros continuous_detection.launch
… logging to /home/husarion/.ros/log/fa12322e-4e76-11ea-beed-409f384f007f/roslaunch-husarion-11715.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://husarion:36935/



  • /apriltag_ros_continuous_node/


  • /apriltag_ros_continuous_node/camera_frame: camera
  • /apriltag_ros_continuous_node/publish_tag_detections_image: True
  • /apriltag_ros_continuous_node/publish_tf: True
  • /apriltag_ros_continuous_node/standalone_tags: []
  • /apriltag_ros_continuous_node/tag_blur: 0.0
  • /apriltag_ros_continuous_node/tag_bundles: []
  • /apriltag_ros_continuous_node/tag_debug: 0
  • /apriltag_ros_continuous_node/tag_decimate: 1.0
  • /apriltag_ros_continuous_node/tag_family: tag36h11
  • /apriltag_ros_continuous_node/tag_refine_edges: 1
  • /apriltag_ros_continuous_node/tag_threads: 2
  • /rosdistro: kinetic
  • /rosversion: 1.12.14

apriltag_ros_continuous_node (apriltag_ros/apriltag_ros_continuous_node)

auto-starting new master
process[master]: started with pid [11725]

setting /run_id to fa12322e-4e76-11ea-beed-409f384f007f
process[rosout-1]: started with pid [11738]
started core service [/rosout]
ERROR: cannot launch node of type [apriltag_ros/apriltag_ros_continuous_node]: can’t locate node [apriltag_ros_continuous_node] in package [apriltag_ros]

But the node in the correct location on the package.

Hello Thiaga,

It looks like workspace is not built or sourced correctly.

Are you able to locate package? E.g. with:

rospack find apriltag_ros

Are you able to run the node separately? E.g. with:

rosrun apriltag_ros apriltag_ros_continuous_node


1 Like

Yeah I fixed this thanks Lukasz. The problem was with sourcing. After sourcing to devel_isolated it worked.