[Solved] Panther RUTx11 GPS not reporting


I’ve been doing some outdoor operation of our Panther for RMIT. I’ve encountered an issue with our GPS in the RUTx11. We haven’t used the GPS previously as we’ve operated indoors.

The GPS is not reporting any values. I’ve tried going through the RUTx11 documentation and yet to solve the issue. The GPS is reporting a position of zero from the gpsctl command:

root@Teltonika-RUTX11:~# gpsctl -ixap

I’ve tried turning on/off the various GPS satellite configurations and restarting the gpsd process with no success. The robot has been outdoor during the day so clear-sky is not an issue. I’ve also checked and the antenna cable from the black dome is securely connected to the RUTx11 internal box.

Any suggestions on potential issues would be greatly appreciated.


Hi Tim,

First, double-check that the antenna is correctly connected. Pay particular attention to the cable with the blue sheath, which should be plugged and secured to the port marked as GPS on RUTX11. Please note that after reboot or changing router configuration it may take a while for GPS to start publishing meaningful data.

You can also try using a different GPS antenna. With every order such antenna is sent in box with the accessories:

If this doesn’t help please perform this simple test to decode the raw GPS data stream and check the status of the GNNS receiver:

  • Log into Built-in Computer: ssh husarion@
  • If you are using nmea-gps docker, you have to stop it (the easiest way is to stop the whole compose with docker compose down)
  • Run: sudo systemctl stop gpsd.socket
  • Run: gpsd -N udp://
  • In separate SSH session run: gpsmon, if it is not installed run: sudo apt-get install gpsd-clients
  • Send the output of the above command

Best regards,

Hi Dawid,

Thanks for getting back and the suggestions. To confirm, I checked the antenna before travelling and it was very well secured (and see below which confirms I can eventually get a position).

I’ve taken a further look and have a strange discovery.

When I reboot Panther (turn off/on), then the GPS fails to report a position. (I’ve found it easiest to test the GPS from logging into the RUT (.1) and running gpsctl -ixape.) That is, I get 0’s for the pos as below, and the ros nmea package reports lat/long as nan/zero.

root@Teltonika-RUTX11: gpsctl -ixape

However, if I do the following:

  • Log-into Pi (.2)
  • Terminate gpsd service sudo systemctl stop gpsd.socket
  • Terminate docker (if it’s running - but I don’t run it by default atm)
  • Run gpsmon
    Then then GPS report a position, and the ros nmea package reports valid lat/long. (I’ve cut out the decimals but they do correctly point to my location when testing).
root@Teltonika-RUTX11: gpsctl -ixape
2024-01-08 23:44:10

This works until I reboot Panther.

It seems gpsdmon is triggering something to start-up the position reporting.
I’ve tried looking at the RUTx11 documentation, but I can’t find anything. So suggestions would be very welcome.

Could you please check the RUTX firmware version and RPi OS version?
For the router, log into it and run:

cat /etc/version

For RPi, log into it and run:


Hi Dawid,

RUTx11 firmware: 7.03.02
Pi: v1.1.2

I have just updated the RUTx11 firmware to 7.06.01.


Issue was resolved during call. It was caused by old modem firmware on RUTX11.
In case of similiar issues please check if you are running on newest modem firmware.
You can check under Status → System Tab (as shown here).
As of today (23.01.2024) newest modem firmware version is:

  • Europe, The Middle East, Africa, Australia, APAC, Brazil, Malaysia - EG06ELAR04A20M4G
  • North America - EG06ALAR04A01M4G_01.001.01.001
1 Like