[Solved] Quick Start ROSbot 2R

Step1 was when I downloaded the Galactic image.

Step 2 was when I edited the network config file with my WiFi access point and password.

Step 3 was when I connected to my ROSbot2R in a terminal window from my laptop.

Step 4 was when I pulled the basic docker images for ROSbot.
docker compose pull

I was told there was no configuration file found. Can anyone help me to determine which of my steps I performed incorrectly, please? I would like to use my ROSbot2R using ROS2. If that’s not possible yet please let me know so I don’t waste my time debugging my environment.

Sorry for the intrusion.

I am running ROS2 on a rosbot with an Rpi4.

Please post a log file with your errors.

Also look at GitHub - husarion/rosbot_ros: ROS packages for ROSbot 2, 2R and 2 PRO

Congratulations! There is no log file but I can duplicate my terminal command and response here.

$> ssh husarion@
I received a response stating:
Website: https://husarion.com
OS: 20.04.4 LTS (Focal Fossa)
Kernel: 5.4.0-1052-raspi
Board: None
Uptime: 3m.
Memory: 6572MB / 29946MB (22%)

husarion@husarion:~$ docker compose pull
no configuration file provided: not found

Where would I find the log file?

Sorry I didn’t list the contents of the home directory.

compose.minimal.yaml compose.rviz-demo.yaml default.rviz Desktop Documents Downloads Music Pictures Public Templates Videos

I decided to look in the home directory of my noetic sd card and it has the magical configuration file compose.yaml. It, of course, doesn’t pull the proper packages for galactic so I wonder how someone got that to work?

May I please have the compose.yaml file meant for ROS2?

Hi Joe,

I have attached a sample compose file to bring up the sensors on a rosbot.

# Quick Start
# $ docker compose -f compose.rosbot.hardware.yaml up

    image: husarion/rplidar:humble
    restart: unless-stopped
      - /dev/ttyUSB0
    command: >
        ros2 launch sllidar_ros2 sllidar_launch.py

    image: microros/micro-ros-agent:humble
    restart: unless-stopped
    command: serial -D ${SERIAL_PORT:-/dev/ttyAMA0}  serial -b 576000 # -v6
      - ./micro-ros_entrypoint.sh:/micro-ros_entrypoint.sh
      - ${SERIAL_PORT:-/dev/ttyAMA0}

    image: husarion/rosbot:humble
    restart: unless-stopped
    command: >
      ros2 launch rosbot_bringup rosbot_bringup.launch.py

This file can be run using

docker compose -f compose.rosbot.hardware.yaml up

Thanks. Now I’m really uncomfortable with phrases like “sample compose file to bring up sensors on a rosbot” It’s only a sample until the real one gets tested and published? Does this work only on ROSbot2R?

Is this a published file or documented somewhere or did you merely do this as a support favor? I’m uncomfortable with “This file can be run using…” Why does this not match the already published Quick Start? I’m sure this all works and thanks for the “sample” file. I may try it and continue but I’m having difficulty following all the changes, additions, and corrections.

Perhaps I should wait several months until the ROSbot2R is fully updated including documentation and repositories and internal hardware, etc. I understand that everything is being worked on but I’m too old to play in sandboxes. Great little vehicle but I haven’t been able to make it perform yet. I’m slowly getting there. Looking forward to some of the more advanced tutorials but I’m struggling with the Quick Start tutorials.

I just discovered that the galactic image for SD cards has changed. Different date and name than what I downloaded only a few weeks ago. As a matter of fact, that’s what the first post in this chain states. Again, I apologize for not supplying the name of the image which may have been a clue to someone. Anyway, when I went to place the recommended “sample” compose file, I discovered the real compose.yaml appeared in the home directory which doesn’t match what I documented in an earlier post. I can’t keep up with the changes.
I am pulling images now and will report my progress.

Hi Joe, re the sample file posted above, I am using the file I posted on my rosbot/RPi4 system and it is working.

Got the files and even managed to learn how to use sync_with_rosbot.sh properly. Clever way to verify software matches. Good job! This is closed.