[Solved] RobotModel Status error caused by missing links to map

I just cloned rosbot_description and tried what was there in the readme but when i launched rviz i noticed this. I’m not sure what i should do.

Hello @Poornima_Nair,

Repo description_rosbot is outdated. You can find the currently supported code for ROSbot here GitHub - husarion/rosbot_ros: ROS packages for ROSbot 2, 2R and 2 PRO.

If you are starting your journey with ROSbot check How to start | Husarion
If you are looking for something specific, I will be happy to help.


Ahh thank you for your help, i figured out it was due to a missing dependancy (gazebo-ros-control). Im pretty much a beginner at ros but from my understanding, there is a line that’s supposed to download all the required dependencies but it doesn’t really download lots of them. I’ve been manually downloading them when errors are thrown, but fixing this was tricky.

I’m glad you managed to solve the problem.

I have set a counter for this post in case you have any new questions regarding this matter.

hi i have another question, are the tutorials in tutorial_pkg supposed to work in the gazebo simulation aswell?

Hello @Poornima_Nair ,

That’s right, this is a repo that reflects the work done in our tutorials.
Starting Your ROS Journey | Husarion. Note that you need to change the ros2 / ros1 branch depending on your platform.