[Solved] ROS 2 Tutorial -> 8. SLAM - No /scan_filtered on ROSbot

Hi, I’m Amin

I am currently experimenting with ROSbot 2 PRO. Right now I’m following the SLAM tutorial on this specific page ROS2 SLAM . I have run every possible and docker images required for ROSbot 2 PRO.

Problem is I reach a dead end because in the picture below it specifically said I need to have /scan_filtered topic which I don’t have, I do have /scan topic instead. What is the problem here?

Welcome @hellofathul,

Thank you for your question. The article focuses on ROSbot XL, equipped with a lidar that can detect itself (e.g. Wi-Fi antenna) due to its size. With ROSbot 2R and 2 PRO there is no such issue, so feel free to use the /scan topic instead of /scan_filtered . :wink:

To do this, you can:

  1. Remap the topic in the container:

    • open compose line,
    • find rplidar service,
    • add topic remapping to command --ros-args -r /scan:=/scan_filtered
  2. Update YAML parameters:

    • check for *.yaml parameter files,
    • replace all occurrences of scan_filtered with scan.

All parameters have been configured for the size and characteristics of ROSbot XL, so remapping the topic itself should help, but the navigation needs to be improved on your own. For ROSbot 2R / 2 PRO you can also use the repository: GitHub - husarion/rosbot-autonomy: Autonomous navigation & mapping for ROSbot 2R / 2 PRO

I appreciate your question, and I encourage continuous learning. Let me know if it helped.

Happy Coding!

This topic was automatically closed after 9 days. New replies are no longer allowed.