[Solved] ROS Difficulties (Noetic)

Teleop_twist_keyboard doesn’t launch and needs rosdep installed, but doing that destroys the OS. Once rosdep is installed, it removes a bunch of the ros-noetic packages.

Can’t find object_2d_node - confused at tutorial 4. Attempted to install manually as per GitHub - introlab/find-object: Find-Object project but there’s no instructions for installing on noetic.

All the tutorials on the site seem to be geared towards melodic, not noetic. How much of an issue is that? I’ve been having issues with every single tutorial from the website, and I’m not sure if that’s my ignorance of ROS or if there are incompatibilities in the tutorial that cause issues for everyone.

I realize that this post is not particularly detailed, but I figured I’d throw out a feeler and provide details as needed. Let me know if there’s more info I should include, and thanks for your time :slight_smile:

Hi clintonamoar

First of all i will need some details about the OS image you are using on your robot.
Can you tell me witch image have you installed? (The date should be in the image name).
Allso it is really important that you tell me witch robot you are using.

Regarding the problems with package instalation we racomend using apt instead of rosdep. For example Teleop_twist_keyboard should be installed like this:
sudo apt install ros-noetic-teleop-twist-keyboard

As for the problems regarding specific tutorials they all should work fine on noetic. My first guess is that your noetic OS image might be a bit outdated.
If you are using the latest image then i will need some logs and details about your problems with the tutorials.

I will be waiting for Your response and hope to help :smiley:

I am using the image from this link (ros-noetic-arm-2021-02-12.img), I do not see any newer links. In the system when I launch roscore, the distro & version are shown:
/rosdistro: noetic
/rosversion: 1.15.9

and running "cat /etc/os-release" tells me I’m running Ubuntu v 20.04.2 LTS.

I am running this on a Husarion ROSbot 2.0, S/N: 964857

I will collect logs and send shortly.

On a fresh install with that image, after running ./flash_firmware.sh, I can run roscore and roslaunch astra_launch astra.launch just fine, but when I go to run rosrun image_view image_view image:=/camera/rgb/image_raw it gives me the error "[rospack] Error: package 'image_view' not found".

I try "sudo apt install image_view", but this gives the error "Waiting for cache lock: Could not get lock /var/lib/dpkg/lock-frontend. It is held by process 1836 (unattended-upgr)".

I try "sudo apt update" and get a whole list of errors stating why apt cannot be updated.
This is fine; I’ve had success manually cloning the github repo.

I can move past that point, and view the raw camera image, but when I enter "rosrun teleop_twist_keyboard teleop_twist_keyboard.py", the error "the rosdep view is empty: call 'sudo rosdep init' and 'rosdep update'" appears, then endlessly says "Waiting for subscriber to connect to /cmd_vel".

Thanks for your description of the problem.
We will investigate the issues with specific commands and address them.

I will contact you as soon as we have some information

Sorry for the inconvenience.

Thank you Nicolas!

I did some more investigating and it turns out the reason sudo apt update doesn’t work is because the Husarnet keys have expired (as someone noticed here). I updated them and was able to update apt, but the keys will expire in a few months.

Would it be possible for you send me the blank image file you used as a base for installing ROS on the Asus Tinkerboard? I would like to try installing ROS from a fresh Ubuntu image with nothing else on it. I have looked many places on the internet and have not had any success finding a .img file that will work with the ARM processor in the Tinkerboard besides what is provided on your website.

Hi i would recommend using our image.

Asus does not provide a ubuntu image for their Thinkerboard and ours is a fully custom image.

You can try make it yourself but there is no raw Ubuntu image for Thinkerboard.
Its not a easy process to customize a image to make it work with Ubuntu.

One important note is that husarnet keys dont expire as quickly as before so that should not be an issue.

Hi Nicolas,

Have you and your team had any luck with those specific commands that I was having issues with? I’m still stuck on in going through the tutorials since many of the commands I try don’t work.

I am also still concerned about the error message:
W: failed to fetch https://packages/ros/org/ros/ubuntu/dists/bionic/InRelease The following signatures were invalid: EXPKEYSIG F42ED6FBAB17C654 Open Robotics <info@osrfoundation.org>
It is frustrating and concerning to have the image directly from your website have signature/key issues right off the bat, experiencing roadblocks with a command as simple as sudo apt update.


Yes we have encountered these issues recently.
We will be looking into it and fix it as soon as possible.
When I have any further information i will update you.

Hi Nicolas,

I am facing the same issue described here where teleop node is stuck at Waiting for subscriber to connect to /cmd_vel.
I am also using the img: ros-noetic-arm-2021-02-12.img
Please let me know if you were able to identify a fix for the same.

Hello @AkshayaKS and welcome to Husarion Community!

First, I have to ask, are you starting up the system as described in the basic ROSbot 2.0 tutorial? If not, I suggest going through this Tutorial (linked below) or a more detailed description of how you boot your system.

Best regards
Jan Brzyk

Thank you for your reply. I was able to resolve this issue by running:
docker compose up -d rosbot
to get the required topics available. Then teleop ran ok.

Hello @AkshayaKS

so the problem has been solved. Thank you for your answer.

Best regards
Jan Brzyk