[Solved] Rosbost-xl navigation problems

After a few weeks trying to solve the communication problem in [Solved] Rosbotxl navigation problem - #2 by RafalGorecki I realized the problem was in the middleware so I try a different approach: install vnc server in the robot and run everything on it.
When I use this approach, I run the robot compose in one prompt and the RVIZ in other prompt, everything is fine until I send a goal through RVIZ the robot start spinning and finally show goal failed message in the command prompt.
Is there some issue related with this behavior?

Hello @avillaj88,

I need more information to understand the problem you are facing.

Please tell me which exact repository for rosbot-xl you are using. We have three repositories that cover the topic of navigation: rosbot-xl-mapping, rosbot-xl-navigation, rosbot-xl-autonomy. Additionally, you can send a photo/gif showing the problem.

One potential solution may be to enter a destination point outside the global map - the area marked in the photo below with a red line. The global map should automatically increase if slam receives data from outside the map.

Were you able to resolve the issues in the previous query or do you have any questions regarding the previous query?


Hello @RafalGorecki

Sorry, I am using the rosbot-xl-autonomy repository, and the problem is only with navigation. I did the slam using the rosbot-xl-mapping repository and everything was fine.

Regarding the other thread I realize that the solution was use fastdds middleware but when I use it some of the nodes from the navigation stack crashed and when I managed to run everything using fastdds I got the same behavior, so I decided to find another approach due cyclonedds is more stable.

As I explained before this new approach consists in execute all the dockers inside the robot and acces it through vpn. To start I run in a promt the docker compose up command and in another prompt the docker compose -f compose.pc.yaml up. I get all the components from the robot running (see rqt_graph output below) and the rviz with the map and the robot. So far all good, but when I select a point in the map to set the goal the robot start to spinning, finally it riverses and stop (see rviz figure) and showme in the prompt goal failed. Every time I run the system I got the same behavior the only thing different is the total spinning angle.

Thank you in advance,

  1. Have you made any changes to the repository, what is your .env file configuration?
  2. What SBC is mounted inside your ROSbot (RPi4, NUC, NVIDIA)?

We have the RPi4 and we are using the normal wheels.

Below you will find the .env configuration:





Hello @avillaj88,

Thank you for this information. We also noticed this bug in ROSbot 2R. Which is most likely due to the relatively low computing power of RPi4. I’m currently working on simplifying and optimizing the code to allow the robot to run smoothly, so please be patient.

I quickly transferred my optimizations from ROSbot 2R to the rosbot-xl-autonomy repository on branch devel: GitHub - husarion/rosbot-xl-autonomy at devel.

The optimizations are in the testing phase and have not been officially implemented yet, so new problems may arise, but the navigation itself should be more stable.

If there are any errors, I will be able to help you with minor issues. In case of major problems, please be patient, you can expect an update in this area in the next month. Please also let me know if it works for you.

Rafał Górecki

Hello @RafalGorecki ,
Yesterday I tryed with the devel branch but I could not test the system because always rised this error when I tryed to run the docker compose up command:

Bugs dependency failed to start: container rosbot-xl-autonomy-rosbot-xl-1 has no healthcheck configured

Thank you so mouch for the help,

To fix this, you need to change compose.yaml you have to options:

  1. Delete unnecessary depends_on
rosbot-xl: { condition: service_healthy }
  1. Use newer version of docker image
    image: husarion/rosbot-xl:humble-0.8.12-20231219

Let me now does it helps.

Merry Christmas,

Hello @avillaj88,
Have you encountered any other problems?

Hello @RafalGorecki,
Currently I am out of the office, I have not been able to perform any other tests.

Hello @RafalGorecki

Today I came back to the office and tried your suggestions, everything works fine. Sometimes there is a small error in the orientation at the goal point but as I said it is very small.

Thank you very much for your support and happy new year!!!


1 Like

This topic was automatically closed after 4 days. New replies are no longer allowed.