[Solved] ROSBot 2.0 / rosbot-2.0-fw-v0.14.2.bin: CSER config command not working / Servo not powered up


I have a ROSBot 2.0 and I am trying to get a servo running. But even the power supply pin does not output any voltage.

Is there a hardware issue in my robot?

I have downloaded and flashed the STM firmware rosbot-2.0-fw-v0.14.2.bin

by issuing the following command:

husarion@husarion:~$ rosservice call /config “command: ‘CSER’
data: ‘V:1 S:1 E:1 P:1000 W:0’”
data: ‘’
result: 0

nothing happens. The result information shows always that the data is recognized as an empty string.

There is no voltage out switched on.

What do I miss? What am I doing wrong?

My best regards, Matthias

Hi matthias,

Please flash the newest firmware according to tips from this topic, and try one more time, :slight_smile: It should help.

Best regards,

Hi Hubert,

unfortunately the servo PWM is still not working after updating the firmware to 0.15.0 and using the latest rosbot_ekf. There is no power on the power out pin and also no pwm signal after issuing this command:

rostopic pub /cmd_ser std_msgs/UInt32 “data: 0x3E81” --once

Hi Matthias,

It’s probably mean that it is a hardware issue. I will contact you directly and send you instruction how to send us ROSbot back for repair :slight_smile:

Best regards,