[Solved] ROSBot 2 does not turn off with the switch

I have a ROSBot 2 and it has been working fine, but since yesterday it doesn’t turn off with the switch, the only way to turn it off is to take out the batteries. I have seen the same issue raised in this topic: [Solved] ROSBot 2.0 switch does not turn bot off
and I have carried out the measurements:
2.: 0
3.: 0
4.: 0
5.: 0
7.: 0.03
Could I ask for help about what my next steps should be?
Thank you in advance!


I’m sorry @Veronika, but your first community post won’t contain some clever solutiont to fix this.

Unfortunately, your measurements indicate that the transistor on the board has burned out. As a consolation, I will add that it is probably better for you that ROSbot did not turn off than that it did not want to turn on.

If you have any further questions, I will keep in touch.

Rafał Górecki

Hi Rafał,
Thank you for your response!
Fortunately, the robot is working, the issue was simpler than it looked. One of my colleagues detected that the power switch on the Core2 board was accidentally turned to the ON position, and that was overruling the main external switch.

1 Like

Hi @Veronika,

Thank you very much for letting us know what caused the problem and we are glad that we managed to find the cause.

Warm greetings,

This topic was automatically closed after 4 days. New replies are no longer allowed.