[Solved] ROSbot 2R Navigation Tutorial

I am using the ROSbot2R and completed the Mapping tutorial to create a map of my environment. My SBC is running Humble with Ubuntu 22 acquired on your downloads.

Upon running the navigation tutorial on my ROSbot2R
cd ~/rosbot-navigation && docker compose -f compose.rosbot.yaml up

My output generated was as follows:
[+] Running 13/19
⠸ navigation Pulling 160.2s
⠿ 0509fae36eb0 Already exists 11.2s
⠿ 11760287344b Already exists 12.3s
⠿ 57286bbac2dc Already exists 12.9s
⠿ 9fe77194dbcb Already exists 13.1s
⠿ ffeeadbd7d6f Already exists 13.3s
⠿ fae686679d19 Pull complete 49.4s
⠿ bfc6e6b49e00 Pull complete 83.9s
⠸ localization Pulling 160.2s
⠿ 3a9d5bd38521 Pull complete 64.3s
⠿ b6abeb480120 Pull complete 82.5s
⠿ ea688560ca6a Pull complete 83.2s
⠿ 4f4fb700ef54 Pull complete 83.4s
⠿ 90129fa207dc Pull complete 83.6s
⠿ 337109148d54 Pull complete 83.8s
⠸ 6345d1351b4a Extracting [==================================================>] 596.2MB/596.2MB 158.3s
⠸ 419156d691ab Download complete 158.3s
⠸ 82a638bdbf64 Download complete 158.3s
⠸ 20ffd83d4772 Download complete 158.3s
failed to register layer: Error processing tar file(exit status 1): lchown /usr/lib/aarch64-linux-gnu/libvulkan_lvp.so: read-only file system

I am unsure if the docker container extraction is causing the problem or saving it to my filesystem is the problem. Does anyone have any suggestions?


WOW! I was not aware that cheap micro sd cards can fail and become read-only during their infancy. Fortunately I was able to create an image of the card and restore it to a good card albeit the same manufacturer…Kexin!
Navigation tutorial complete so this should be solved.


Interesting case. This proves that it is best to use quality equipment in such situtions.
Thank you for your conclusions @Joe_Worthit !

Best regards
Jan Brzyk