[Solved] ROSbot 2R - ROS Tutorial 5. catkin_make problem


I am using RosBot2R-noetics and I followed every step of the “How To Start” so far so good
But in Ros Tutorials > 1.Ros Introduction >> Starting camera >> 5. Build the package in workspace
every time I do catkin_make command the system hang and freeze and I cant do anything, I have to shutdown and start again so I can open the system.

btw when I connect to the screen using HDMI the screen is not clear and display a green/red glitchy dots

I hope you can help, thank you

Hi @musta,

What you are saying is very unusual and I’m not sure if the two phenomena are related. The problem with HDMI may occur if you use a VGA adapter or the HDMI cable is already heavily used. If possible, test the socket with a different cable.

When starting bugs with starting catkin_make, it is worth trying to update the system or reinstall it, especially if ROSbot was already purchased a long time ago.

  1. System update.
sudo apt-get update
sudo apt-get upgrade
  1. Check if the problem occurs when building an empty package?
    Please contact us again.
mkdir src
  1. Monitor system resources (CPU, memory, disk usage) while running catkin_make to identify potential resource bottlenecks.

  2. Reinstalling the system.

Here you can find instructions for reinstalling the system link (remember to select the appropriate NUC/Raspberry PI hardware configuration). It is best to use a new SD card for this, which will reduce the chances that the current SD card is corrupted. If the problem persists.

If none of these things brought the desired effect, please contact us again.

Best regards,
Rafał Górecki


it turns out the freezing problem was from the sd card it self, we were using 128Gb sd card.
we switch to a 32Gb and it worked fine, even the 64Gb.

thank you for your response.

Best regards

1 Like