[Solved] ROSBot 2R - Will not power-on (hardware issue)

We haven’t used the 2R much since we bought it in November (maybe on an hour or so), but recently when I plugged in the charger, it indicated 2 of the 3 cells were at 0V. Tried again, but this time 1 was at 0V and another at 2.4v.

However, the short-circuit voltage of all 3 is around 4.2v. I ordered 2 more batteries and a charger, but even after charging the new batteries and one of the old ones completely, I had the same result with the charger and the 2R won’t power on.

Any ideas?

Hello @Steve_Willoughby and welcome to Husarion Community!

Please start with a thorough review of our ROSbot battery charging manual available here, checking the correct location of the battery in the robot and going through the tutorial again step by step.

Can you please provide the serial number of your ROSbot?

Best regards
Jan Brzyk

Hi Jan,

Yes, I’m following the instructions in the charging manual. That process has worked until now, and even now there are no error msgs from the charger. The batteries are firmly in place.

I just tried using the “LiPo Balance” mode instead of “LiPo Charge”, and when the charge cycle is started, it halts immediately with the error, “LiPo Vol Error Cell Connect.” This happens either using the 3 original batteries or 1 of the original batteries and 2 new 3200mAh 18650 batteries. Again, all the batteries have a 4.2V short circuit voltage.

The s/n is 193537.


All that was in the upgrade kit was a short usb cable, a right-angle SMA connector, and a small cylindrical piece of plastic. We were definitely confused on how that would improve power management! However, I will install today.

Yes, Hal is “in the loop” on the situation…


Okay, I’m waiting for the updates.

Best regards
Jan Brzyk

The changes did not alter the charging behavior.

Summary so far:

  • The voltage of all 3 of the original batteries measures 4.1 to 4.2v with a multimeter, which, without measuring capacity, would indicate the batteries are good.
  • The Redox Beta charger will complete a cycle in Charge mode, but one or two of the batteries always show 0.0v in the display.
  • The charger’s Balance mode fails with this error: “LiPo Vol Error Cell Connect.”
  • I plugged the barrel connector from the charger’s power supply into the jack next to the charger connector on the robot, but it does not power on (this was in the charging manual in the “Stationary use of ROSbot” section) BTW, the position of the barrel jack on the back of our robot differs from the ROSbot 2R manual.

The “LiPo Vol Error Cell Connect” error for this type of charger could mean a few things, including a bad connection to the charger, a balance lead not connected in a battery, a poor connection in the robot, a defective charger, or one or more “bad” batteries. Doesn’t narrow it down much. The connectors fit well, but I haven’t measured continuity.

Even though the original batteries appear to be fine (mearsuring 4.1 to 4.2v), maybe instead of over-analyzing this, the logical place to start would be to try 3 new batteries (I currently only have 2 new batteries.) Meanwhile, I have a different charger and am charging the original batteries with that.

Or do you have a different suggestion? Have you seen this behavior before? Why wouldn’t connecting the charger power supply to the robot allow me to power it up?


Quick update. I charged all 3 original batteries on a different charger, put them in the robot, and it still will not power on.


We were not sure if your robot does not fully turn on, or behaves like completely unpowered all the time, without the LED light on the rear panel. I suppose that you observe the second case. In case when robot does not work on batteries and also on the power supply, it could unfortunately mean a problem inside the robot.

  1. Is there a chance that you used a different power supply than included with ROSbot? With the higher voltage?
  2. Have you noticed any visual damage to the charging cables and connectors?
  3. Have you used any external device with the robot, which could be incompatible with it?
  4. If you answer “no” to all above questions, could you please agree the remote diagnosis via private messages or videoconference? Or you prefer to send it back for the warranty service?

Hi @radeknh!

The robot shows no indication that it has power when the switch is turned on. The external LEDs are all dark. The answer to each of the other questions is “no.” We’ve barely used the robot, so it’s in pristine condition.

I would much rather take the remote diagnosis route! PMs, video conf, or both would be great.


We close the topic as the hardware issue has been fixed.