[Solved] Rosbot cannot move

Hi. The robot is okay moving before but now it cannot move. does it need the battery to move? I try using power supply and do a simple example as shown here (Simple kinematics for mobile robot | Husarion) . /cmd_vel have value but the wheel is not moving at all. other data like battery, velocity, imu from the driver is received ok. its just it does not move. How do i troubleshoot this issue? is it because i am using power supply? the battery currently is so low i cannot charge it using the given charger. I will change battery or externally charge it later.

Hi melloremell.

The robot should be able to drive without batteries. Please let me know as soon as you will get new batteries. If it still doesn’t move, than we will have to check what might be the problem.

Best regards,
Krzysztof Wojciechowski.

i already change the battery now it can move. can you advice what could be the reason and how can i solve it?

Hi melloremell,

You have to observe LED L1. If it starts blinking, that’s mean that battery level is low. In this case, firmware will disable motors (check description here) to prevent a voltage drop that can cause the SBC reset, which could lead to the loss of unsaved data.

Best regards,