[Solved] Sync workspace with ROSbot

I am attempting to configure the autonomous navigation and mapping demo found at here

After cloning the repository on my host, the copy command to make .env failed because there was no template file. So I created one and copied the sample into it.

When I try to run the sync with robot script I get:
Contacting server…
Host key verification failed.
Setting up watches. Beware: since -r was given, this may take a while!
Watches established.

and the terminal is locked.

There is no syncing because trying to run the containers from the demo on the ROSbot, the files aren’t there. Am I mistaken in believing this should have made a copy on ROSbot or am I supposed to clone it first on the ROSbot?? That step is not in the tutorial so I hesitate to continue without suggestions.

I waited several hours but nothing happened. Should I clone the repository on my ROSbot2R and continue with the demo?

I decided to clone the repository on my ROSbot2R. I brought the ros1 containers up and followed the instructions to run xhost and bring the mapping containers up. I the brought up the rviz container on my laptop and displayed no map or robot. Just a white object that sort of looks like the ROSbot and errors show nothing being published. I’m way in too deep so all I could do was take a screen shot.

My screenshot probably is not as useful as the fact I can install Ubuntu 20 and Docker on several environments here and still get no display on rviz.

VM machine on Windows 11 running Ubuntu 20 and Docker
Pinebook Pro running Manjaro Linux and Docker
Thomson NEO 10 running Ubuntu 20 and Docker from live USB drive

System 76 Meerkat running Ubuntu 20 and Docker with ROS Foxy and Robotis Turtlebot3 environment. I GET AN RVIZ DISPLAY!!!

The first three were built from scratch. The Meerkat was already in my lab and I merely installed Docker. It’s a mini desktop and not portable.

I don’t know what to do next…

Oops! Got up this morning and fired everything back up…NO RVIZ DISPLAY. Perhaps it has something to do with the weather? I’m still debugging…

And double Oops! Apparently wiggling the antenna on my ROSbot2R causes it to work and I get rviz displays. That must be the part I just received from Husarion that somehow goes in the WiFi antenna.

The part I received seemed to have tightened up a noisy or loose connection to the antenna. Map displays work on all scenarios (even Raspbios and Docker) now EXCEPT the VM machine and the Pinebook PRO.

I don’t really care about network communication problems with the virtual machine but I have plans for the Pinebook Pro running Manjaro Linux to be my ROS robot development platform. Very nice machine.

Perhaps a new topic for the Pinebook Pro in case there are other users.

BTW—The Pinebook is the ONLY platform that could connect to the rsync(?) server for syncing with the ROSbot2R. But my new topic will describe the subsequent problems.

This topic can be closed as solved.