Trouble connecting core2 mini and RPi

Hi -

I have a RPi and both a core2 and a core2 mini. I had the core2/RPi combo working (i.e. connecting to the web interface and uploading programs, etc.) I replaced the core2 with the core2 mini and now I can’t connect. When I hold down hCfg and turn on power, I get the following:

red PWR Light is always on
green L1 is always on

blue LR2 comes on for about 3 sec
yellow LR2 and green L2 flash
blue LR2 flashes 2-4 times then stays on for about 10-15 sec
yellow LR1 flashes once and blue LR2 begins to flash at about 2Hz

I can hold hCfg for a minute or more and nothing else happens.

Can you please advise what I need to do? I am assuming the same RPi image will work for both core2 and core2 mini.


Hi jsmarion,

Your CORE2mini is in the Connecting mode (you can check Status LEDs from our manual). It’s mean that controller can’t connect itself to the internet. Maybe hCfg button is damaged, please try to connect solder pads from both side of the button when turning on and let me know what is the status.


Thanks for the response.

I tried that. It didn’t help.

I re-flashed the RPi image. Now I get the blue/yellow alternating flashing LEDs indicating config mode. On my phone I can connect to the HuasrionConfigXXXXX network, but the app doesn’t find the CORE2mini. Any ideas?

Hi jsmarion,

Just to be sure, you can connect your phone to proper HusarionConfigXXXX network, but app does’t see, hangs in this moment:

In this case I recommend you to do it using another Android or iOS device. I’m waiting for the results.


Thanks very much!

I had been trying it on my Google Pixel XL, which wasn’t working. It worked on my old Samsung Galaxy S4, which worked.

Now I see this:

And I can log into it on PuTTY.

The only problem I still have is that I am stuck here:


Never mind. It took several reboots, but now I can access the CORE2mini via the web interface and download programs.

Thanks again for the help.

1 Like

Hi Jsmarion,
You have been able to connect to the internet.
I am missing the hCfg button on the CORE2mini.
Appenrently I have to locate the solderpads that represent the button.
Pls help me to locate those pads.

Hi Fred -

Look at the picture of the board here. My board is labeled hCfg instead of hBtn2 for the button on the upper left of the picture closest to the mounting hole. That’s the one I used to connect to the web interface, etc. I am not sure which board version you have. Mine is a V1.0.

If you look lower in the link I sent you, under 4.2 RPi connector, you will find that pin 13 of that connector is labeled hCfg, so you should be able to activate the hCfg function by grounding this pin.

Hope that helps.


Hi John,
Thanks for your swift response.
I am missing the picture, or the link, you are mentioning.

sorry, here is the link: CORE2mini | Husarion

Thanks, John,
I have the same version as yours