Unable to boot Raspi Image

When attempting to boot into the image, I am getting a error:
Not syncing: No working init found. Try passing init= option to kernel. See Linux Documentatio/init.txt fot guidance.

I already reimaged my SD card, redownloaded tried again. Tried a different raspi, tried multiple SD cards.
Anybody else having issues?

Or does anybody have a list of packages that husarion has that are installed on the raspi image?

Hi jayjlow,

Can you write me the exact version of your RPi and when you download this CORE2-ROS image? This will help me to get to the source of your problem.

The list of pkg you asked for:







“ros-kinetic-find-object-2d” “ros-kinetic-frontier-exploration” “ros-kinetic-image-view” “ros-kinetic-navigation” “ros-kinetic-rosbash” “ros-kinetic-rospack” “ros-kinetic-rosserial-python” “ros-kinetic-rplidar-ros” “ros-kinetic-rqt-graph” “ros-kinetic-rviz” “ros-kinetic-slam-gmapping” “ros-kinetic-teleop-twist-keyboard” “ros-kinetic-usb-cam” “ros-kinetic-vision-opencv” “ros-kinetic-compressed-image-transport” “ros-kinetic-astra-camera” “ros-kinetic-astra-launch” “astra-udev-support”


“fonts-roboto” “gnome-icon-theme” “gtk2-engines-pixbuf” “libinput-tools” “libopencv-core-dev” “libopencv-dev” “lightdm” “lxde” “lxinput” “lxpanel” “mesa-utils” “network-manager-gnome” “openbox” “pcmanfm” “policykit-1” “scrot” “tightvncserver” “x11-xserver-utils” “xfce4” “xfce4-session” “xinit” “xrdp” “xserver-xorg” “xserver-xorg-input-libinput” “xserver-xorg-video-fbdev” “zenity” “libpam-kwallet5” “libpam-kwallet4”


“modemmanager” “linux-firmware” “openssh-server” “parted” “rfkill”
“raspberrypi-bootloader” “raspberrypi-kernel” “raspberrypi-sys-mods”

“husarion-motd” “husarion-shield” “husarion-sdk”
“libraspberrypi-bin” “libraspberrypi0” “tinkerboard-kernel”


Raspberry Pi 2 Model B v1.1

And downloaded the image on the 26th of July

Hi jayjlow,

Our image supports only RPi 3 and Asus Tinker Board, so booting RPi 2 on it is impossible. Sorry for the inconvenience.


Im going out a limb and say that your image doesnt support the 3 B+?
Mine won’t boot and it keeps stuck on the rainbow screen, while also displaying the under voltage (lightening bolt) icon. After some research it looks like the boot code is too old.

Hi jayjlow,

Just to make sure. Earlier you said that you are using:

Raspberry Pi 2 Model B v1.1

Now you said:

3 B+

Can you please double-check and confirm which model are you using?

also displaying the under voltage (lightening bolt) icon

What power supply you are using? It is possible that it is not efficient enough.

After some research it looks like the boot code is too old.

Can you let me know what information have you based your conclusion on ?

I am waiting for your answer :wink:


Sorry about that. I was using the Raspberry Pi 2 Model B v1.1. You told me that you only support the raspberry 3, so I purchased the 3 B+.

Its not the powersupply. If you are using an image that the 3 B+ doesn’t support, you get the rainbow image and the lightening symbol.
Im also using the core2 board with a 12v 5 amp powersupply.

If I use an official image from raspberry pi, the latest one available on their website, I have no issue.

Source for what “based [my] conclusion on ?”: STICKY: Is your Pi not booting? (The Boot Problems Sticky) - Raspberry Pi Forums

Hi jayjlow,

Now I understand everything :wink: We already ordered RPi 3 B+. New image which will support this model will be released one or two days after we received device. Sorry for inconvenience.


Is still RPi 3 B+ unsupported? Downloaded image today and cannot bot with RPi 3B+. RPi 3 boots OK.

Hi everyone!

I am pleased to inform you that the new Image available here, now fully support RPi 3 B+. You can enjoy using Asus Tinker Board, RPi 3 B and RPi 3 B+ with just one linux+ROS image. The new version has been checked and its use should not cause any problem.

Best regards,