Webui Demo from Quckstart - unreliable and issues

I have recently purchased a RosBot 2.0 Pro and worked through the Quick start and basic demo programs. I have got it running but the WebUI demo is very unreliable and unstable. I am not sure if it is my expectations or something in the setup, but it seems if the out-of-the box demo is so fragile what chance do I have of getting something operational. I also have a few challenges with general usage which is probably a separate issue, but I thought it best to load everything in here in case there is some inter-connection… here I go:

  • It seems I can only use a screen and keyboard if it is plugged in from power up. If I boot and start from a screen/keyboard, then unplug it to try the vehicle if I then re-plug the screen in I get nothing. This makes it hard to see what the messages are when it stops.

  • I cannot get remote connection to open a screen (from PC or Linux), but I can ‘ssh’. I have been running it from this, but the connection often drops. I don’t know if it is the remote access - or the whole thing dying (I try and Control-C to stop but there is no resposnse… and I cant check given the point above.

The ‘roslaunch rosbot_webui demo_rosbot_pro.launch’ command works and the UI is accessible from a PC or tablet. But the vehicle only stays alive for between 30 seconds and a few minutes before locking up or dying. Sometimes it finishes just turning on the spot, some times it just dies.

I have tried just hitting ‘Explore’ which has worked for a few minutes some times, but usually ends within a minute or so with the vehicle failing. A few times it has travelled to another room and done OK, but it always end in a lockup within a few minutes.

I have tried manually driving it around, but once again, after anything between 30 seconds and 2 minutes - and it is gone. The UI says no messages and the remote shell is not responding.

I have captured a few logs from the screen. I get lots of:

Control loop missed its desired rate of 10.0000Hz… the loop actually took 0.1377 seconds

There are a few messages about ‘unstuck robot’ and one log ended with : Rotate recovery behavior started.

Most of the time when it is alive the map screen looks like the robot is lost. You can see the red outline from the scanner just continually rotating. It look like it should find itself as the scan profile matches the map - but it misses and just keeps rotating. It occasionally lock in but as soon as you move - it is lost again.

I have captured some logs of starting, running and failing (Copy of the ssh session.) Should be accessible here: Log files

So - are my expectations wrong that I should see some pretty reliable and capable operations with the basic demo? I know this is a research tool - but surely the ROS system is more capable than what I am seeing? Do I need help, guidance or a reset on expectations?

Is there anything else I can do to collect logs to help?

Thanks in advance.

Hello Barry_Hendy,

  • The screen will work only when it is plugged since power up. When it gets unplugged, GPU is switched to power saving mode and output is disabled.

  • SSH connection will drop when WiFi connection gets broken or signal is weak. Rest of the issues are also common symptoms for WiFI problems.

There may be some reasons for that:
What is the distance between your devices and WiFI router/access point?
Are there any obstacles like walls between devices and router?
Are there any interferences nearby,e.g. other networks?
Does your router have firewall that may occasionally break connections?


I am just running the vehicle in my house with a mesh wifi system. It is never out of line-of-sight of an access point.

And there is no firewall - just a simple home wifi. The system seems happily connected both the the Husarion Cloud and to my network. I don’t believe it is a wifi access issue.

To verify if the network is not the problem, is it possible for you to switch to a different network?
This could prove that network connection is not the issue.


How different do you want the network to be? I have another wifi access point in the house, but it is on the same modem and ISP. But that only has one point so is probably a weaker signal - but i can try it?

The only other thing I can try is to connect it to my phone as a hotspot - and connect my PC in the same way - but i am not sure my phone will act as a router?

Or I could direct point-2-point my PC and the RosBot, with no access point?

Is this just to address the Remote Access - or do you think it could affect general performance and lock-ups?



ISP will not make difference as it is about local network.
Different make and model of access point will be good.
Phone hotspot also be good for comparison.

It is mainly to test general performance.



I set up my phone as a hotspot and connected the RosBot, my PC and a Linux PC. I was able to ssh from the linux PC to the RosBot and that connection was reliable.

I was still not able to remote connection from my PC and get a desktop. But I could run the WebGUI.

The system was more reliable, which is a big surprise as my home WiFi is a standard TP-link Deco home 3 point mesh. Is it the mesh that is upsetting the Bot?

I was able to run the WebGUI a few times. It might be that I was trying in a hallway and there was not enough room? I tried in the open family room and it did better. At least I can see the log screens now.

So it is behaving better … but I am bemused about the wifi. I might try another router I have for the smart-home setup and see if that works. But it is a single AP so will probably be weaker?

Should I be able to remote desktop from a PC?


Hello Barry,

Good news that you managed to set up connection reliable.
Remote desktop may be blocked by phone hotspot. RDP is using port 3389 while many phones allow only standard ports like 80 and 22.

We are testing ROSbots only with single AP.
If you could test with different router, it will be a good idea.

It may be worth to try different network adapter with support for 5GHz, default WiFi card in ROSbot is 2.4GHz. Please refer to manual for adapter installation.