Panther Intel NUC ROS2 Husarion OS Image Installation Help


Thank you for the information on installing ROS2 Alpha provided to @Tim_RMIT. We are currently in the middle of transitioning the Panther and are having a few issues with writing the image to the Intel NUC.

Currently, when we try to boot from a USB Flash Drive with the
ROS 2 Humble Image (from the Installing Husarion OS Page) the system will perform a restart and will not correctly boot from the USB, it will continue to do this unless we intervene. We are assuming that we have not properly checked/unchecked an option in the BIOS, but would like to confirm with you.

What we have done so far is:

  • Written the Husarion ROS2 OS to a USB flash drive using Etcher.
  • Inserted the USB into the Intel NUC
  • Changed the boot order to prioritise booting from USB (we have also tried to boot manually via F9 from startup).
  • We have tried unchecking some security related BIOS options such as the Intel Software Guard Extensions (SGX) option and Safe Booting.
  • We have also tried both the USB Installer image and the Raw Image provided on the Installing Husarion OS Page page.

Do you have any suggestions as to what we may be doing wrong or additional guidance we could follow?

Thank you.

Hi @Brayden_RMIT,

I send you more detailed instruction:

  1. Hardware Setup:
  • Connect the keyboard, mouse, HDMI, and NUC power supply (19V, 6.3A).
  • Power on the NUC and enter BIOS settings by holding the F2 key.
  1. BIOS Settings:
  • Change Sleep Type Support to Legacy S3 Standby:
    • Navigate to Power > Secondary Power Setting.
    • Set Sleep Type Support to Legacy S3 Standby.
  • Disable Secure Boot:
    • Go to Boot > Secure Boot.
    • Disable Secure Boot.
  • Change After Power Failure to Power On:
    • Navigate to Power > Secondary Power Settings.
    • Set After Power Failure to Power On.
  • Enable Legacy Boot:
    • Go to Boot > Boot Priority.
    • Enable Legacy Boot.
  • Save settings by pressing F10 key.
  1. Operating System Installation:
  • Install the OS on the NUC:
    • Create a bootable USB drive with ROS image.
    • Plug in the USB drive and turn on the NUC.
    • Follow the installation instructions using username ‘husarion’ and password ‘husarion’:
      • Execute sudo ~/ /dev/nvme0n1 and confirm installation with ‘y’ and .
    • Shutdown the system: sudo shutdown now.
    • Remove the USB drive and restart the NUC.

Let me know if it helped, if not, at what stage the problem occurred


1 Like

Hi @RafalGorecki,

Thanks for the quick response and details. I made a mistake, the user computer we are using is not the Intel NUC, it’s the HP Z2 mini G5 workstation. Just two questions regarding this:

  1. I figure that the OS Image for the NUC will not work on the HP, is this correct?
  2. And, there seems to be no legacy boot options, I believe this is confirmed on the HP forums and no Legacy S3 standby option. Am I correct on this?

All the instructions you provided were clear and very helpful.

Sorry again for the confusion, and thanks for your help.


Hello @Brayden_RMIT,

Unfortunately, I don’t have this HP computer with me to check it. As I see, the processor architecture is the same, so the image from the NUC should work.

Unfortunately, I am not able to give you the exact commands that you need to click to start the system from the pendrive. However, all information is usually located in the BIOS in the boot tab.


Hi @RafalGorecki,

Okay that’s fair enough, I will have a deeper look. Thanks again for your help.